Download

Emissive material + use emissive for static lighting = superbad quality lighing

I was trying to mimic a common area light that is available on any 3d package but the quality is really really bad even using production settings.

22f576c5b1ef97eef12667bcc86388511c284faf.jpeg
d2a95197b4d19032e0db250eb0f611722a704253.jpeg

Any tip on this?

You’ll probably need to increase your lightmap resolution on your meshes. But also you can try adjusting the global lightmass settings, from there I would increase lightmass quality and lower smoothing.

Lightmass settings are pretty decent (production preset) and the resolution was high (512 px), I really miss area lights on Unreal Engine.

There’s more lightmass settings beyond the Production preset. Lightmass quality will increase the number of samples, and smoothing will adjust how much they get smoothed together.

Using exclusively emissive materials for lighting is a horrible idea, the results won’t be good. You’ll have to try to get by on area point lights, you can make them tubes as well.

[DevOptions.StaticLightingMaterial] Baselightmass.ini

I found this … it’s useful? EmissiveSampleSize=128 ?? MeshAreaLightGridSize=100 the parameter can control?