Eliminating dark seams at edge of landscape

Hi all –

In my project, I have it setup so that multiple different landscapes automatically spawn next to each other. However, what I’ve noticed is that the directional light in the scene will create these dark seams on the terrain dependent on it’s angle, which makes it obvious that they’re separate landscapes. I’m hoping to try and eliminate these seams if at all possible…

Image for reference.

I could try to hide them under foliage/other meshes, but I was curious if there was a smart way to eliminate this behavior caused by a directional light. Disabling shadows doesn’t seem to work, because its almost like the light isn’t “reaching” the edge, which is causing the darkness.

Is the directional light moveable?

It is, yes! Its moveable and I have static lighting turned off…

Is this a landscape actor, or separate meshes?

Separate landscape actors – I found a couple of work arounds that I think will solve my problem; I just layered a plane on top with the same texture which is ‘good enough’; also thinking of transitioning to the voxel plugin which would create volumetric landscapes which I think would make this a non-issue!

1 Like