Electronic Nodes - Wiring style for blueprint and material editors

I’m really sorry, I thought people that saw my message either had already bought it or were not interested… I feel like I raised it a bit quickly now, but going back wouldn’t be fair to those who bought it at that price. I promise the price won’t evolve from now (unless I add some big features, but that’s not planned in the short term).

(And considering all the messages I got regarding the price, I think the new price is pretty fair)

(But again, really sorry, it’s all my fault, got a bit of pressure and I should have wait)

It’s really not a big problem. I will probably still grab it when I make other purchases during the next sale (which is what I was planning on doing anyway). It’s just that when you posted the warning, I thought there would be enough time to do the impulse buy and grab it at the original price (which is probably what you were aiming for with that post in the first place).

I bought this at the increased price, don’t really care, it’s still a good price imo… but how the heck do I get this installed in a source built engine 4.22.3
I added Marketplace → Electronic Nodes folders to the Plugins folder & rebuilt the VS code, but those folders aren’t appearing in VS. Is it a version thing or a build.cs line somewhere? Thanks.

Hum, try this:
1 - Copy the “Electronic Nodes” folder from the “Marketplace” folder and paste it inside “[your game folder]/Plugins”
2 - Delete the folder “Binaries” and “Intermediate”
3 - Launch UE4 with your game (normally, it will build the plugin at this stage)
4 - Make sure the plugin is activated in the “Edit/Plugins” window

Hope this help, could you tell me if that worked?

(Sorry for the price…)

  1. When wire length is extensive, the rendering becomes wonky.


    It’s not unlike the default editor behavior but hope there’s something that can be done about it.
    The wire render styles in Node Graph Assistant, for example, seem to work better in this particular regard:

  2. Another suggestion - I really like how the anchor point for wires is outside the node:


    Would like to see a setting to make that distance variable and be able to extend it further:

    I think it would improve readability for instances where the end point is behind the starting point (like in the image above).

  3. Force Draw Bubbles: Would it be possible to customize the draw style of that feature?
    I like the general idea, but it is too much by default. A variable to control the frequency/amount of animated “bubbles” would be great.

  4. Was able to compile for 4.18 but can’t get it to work in 4.18 with Node Graph Assistant.
    Electronic Nodes just doesn’t work at all as long as the other plugin is enabled.
    In 4.22 though, it does render as expected.

4.18 is old and support for it might seem irrelevant, but it is still useful especially for other marketplace creators.
If you could try it on your end, It would be much appreciated.

Thank you very much for the very comprehensive feedback :smiley: !

1 - Hum, this comes from the engine optimization, I’ll try to do something about it. Note that the NGA plugin seems to work but it’s because the line are always straight (and that’s not the case with electronic nodes)

2 - Really easy to do, going to do it right now :slight_smile:

3 - I didn’t think that people would actually use that feature, it was more of a fun challenge to me… But as you’re not the first one, I’ll improve this a bit :wink:

4 - Yeah, electronic nodes conflicts with NGA… I sent a message to the creator to discuss what we can do about it :/…
I actually have a 4.18 and 4.19 version ready for people stucked in those versions, but Epic wouldn’t let me put it on the market as “Only latest 3 engine version is allowed for code plugin category”. (I think it’s for the reviewers not to have a lot of versions of Unreal ?)

So thanks again for all your feedbacks, I’m also working on a new secret feature which I expect to be greatly appreciated :slight_smile:
I hope to release the new version this week (or at least some screen of it)

Hey, I got around to fixing my issue. The problem was I didn’t GenerateProjectFiles correctly, I just needed to run as administrator and it all worked out. I added it as an Engine plugin, not project plugin.

It’s beautiful. I might shed a tear.

Ravishingx: Good news :slight_smile: !

[USER=“2759275”]Cpt. Tripfx[/USER]: I think I covered everything with these settings, do you see something else? (It will be available on the next update)

By the way, if you’re using “roundRadius: 0”, I suggest you add some extra reroute-nodes to better control the style:

new_example.png

Awesome, looking forward to the update.

One more suggestion: optional toolbar buttons for “Force Draw Bubbles” and to toggle through disabled/simple/complex from within the blueprint graph (or just on/off toggle). Maybe even a hotkey to show/hide the bubbles.

I missed the cheap price too, oh well.

Is a line width setting something you are looking into adding?

Also, complex drawing with tweaked radius size seems to be having some issues:

Skärmklipp.PNG

Also noted that when zoomed out (even with default settings), the corners aren’t as nice anymore:

And this might be only me, but the “reset to defaults” button doesn’t seem to work…

@eobet Thank you very much for the feedback!

I’ll try to fix this particular case you encountered with tweaked radius, but be aware that I can’t do much if you push the radius toward very high numbers ;).

About the corners zoomed-out, it seems to be a tangent problem, thank you for noticing, it will be fixed on the next update.

Quick note about the next update, I’m working on a “ribbon” feature that will display properly overlapping wires. Here’s a WIP (it’s not finished yet, there’s still some overlapping):

EDIT: About the “Reset to default” button, I’ll take a look on how to make it work, hopefully for the next update!

That’s something you’ll find in Editor Preferences right out of the box:

First of all: Great Work! I really enjoy using your Plugin.

One thing: I would like to have the option to use mixed wiring styles on a per wire type basis (i.e. have simple wiring syle on the execution path but complex wiring on everything else)

I’m happy to announce you the 1.1 update!

New features

Wire Style: You can now specify the horizontal offset you want for nodes (suggested by @Cpt.Trips)

f1_1.png
f1_2.png

Bubble style: You can now customize bubbles a lot more with movement style, size, speed and space(suggested by @Cpt.Trips)

f2_1.png
f2_2.png

Wire style for exec: You can now specify a specific style for exec wire (suggested by @TPuppe)

f3_1.png
f3_2.png

Ribbon style (experimental feature): This feature make overlapping wires more readable by offsetting them.

f4_1.png
f4_2.png

Bugfix

The weird offset when zoom out completely has been fixed (it’s a checkbox because that bug exists in the engine) (reported by @eobet)
[HR][/HR]
What hasn’t been done/fix yet:

Bug: wires becoming wonky when extensive (reported by @Cpt.Trips)
I admit I didn’t look at the code yet, but it’s unlikely to be something easy to fix… Plus, it’s not an electronic nodes bug, but an unreal engine bug.

Bug: conflict with NGA (reported by many people)
That’s not something I can solve from my side only… I contacted the creator last week, but he did not respond yet.
I don’t want to be spammy, so I’ll wait another week before sending him another message (he may be on vacations, who know?)

Feature: toggle draw bubbles from inside the BP editor (suggested by @Cpt.Trips)
I admit I didn’t search on how to do that yet, but that should not be too difficult. I just need to create an icon for that. Should be for the next update!

Feature: not overlapping parent node (suggested by @kavonharvey)
I searched for hours on how to do that, but it’s fare more difficult than what I firstly though. It may still be possible, but I didn’t find a proper way to do this yet.

Bug: issues with complex drawing with big radius (reported by @eobet)
I admit I didn’t quite find the courage to correct this, as I think it’s up to the user to adapt his BP with his Electronic Nodes config. But I’ll fix it, maybe for the next update!

Bug: reset to default doesn’t work (reported by @eobet)
I didn’t find yet how to make it work… But I keep dig this and hope to fix it on the next update!
[HR][/HR]
You should get the update when Epic validate the files I’m about to send them, give them 48h :wink:

You can stop this by adding reroute nodes on the line. I normally do it either side of the screen space if they ever get that long.

I really like the plugin thank you! It makes working in BP really fun.

Hi Mate!

Loving the plugin so far, having nice straight lines is addictive! But I’ve noticed that Anim Graph Evaluation Pulses (so the bolding and moving bubbles on the wire during debugging) are no longer rendering when I have the plugin activated, for both the Simple and Complex modes. Setting the Wire Style to Deactivated resolves the Issue.

To be clear, the regular Blueprint Graph execution pulse renders fine, so I think you’ve just missed something XD

Gossy

@Gossy Thank you very much :)! If you upgrade the plugin to the 1.1 (only on 4.22 for now) and increase the bubble size in the config panel (Editor Preferences/Plugins/Electronic Nodes Plugin) to 3.0 or 4.0, does that solve your problem?

@Herobrine20XX I upgraded to the 1.1 version and the problem has persisted. The bubbles do show up if I use the Force Draw Bubbles option, but that’s not helpful for debugging.

@Gossy I’m sorry, I can’t help you right now as I’m on vacation for a week… I think I see where the problem is! I’ll try to solve this whrn I’m back next week and push it as a hotfix :wink:

No worries!