EG Launcher fails to launch editor. editor.exe fails as well

Hello, I’ve been researching the forums for fixes for weeks and nothing seems to work for me.

I installed unreal engine 4.13.3 and 4.13.2 to my windows drive, verified, uninstalled and cleared registry/directories, and reinstalled multiple times: when I run the launcher from the shortcut or .exe (user or admin) and click the “Launch” button it says “please wait” for about 4 seconds then goes back to saying “launch” again. No process appears in my task manager. I’ve tried installing both 4.13.3 and 4.13.2 on both my main SSD windows drive and my backup HDD windows drive to no effect.

When I run the editor.exe from its directory, i get a message saying I’m missing an “api-ms-win-crt-runtime-l1-1-0.dll”, however when I reinstall all available versions of that .dll I get the same “line missing in dll” error.

I have run vc_redist64.exe and made sure that both my visual redist and graphics drivers are up to date.

I’ve gone through about two dozen fixes from the forums here, but nothing has worked so far.

The dxdiag.txt and zip for my UE4 logs posted below were obtained while I was running version 4.13.2.

Thank you to all help in advance, cheers!

link text

i am having the same issue, even installed all updates that were available, added new targets to the launcher, added physical exceptions to the firewall.

when i checked task manager unrealcefsubprocess sits at 0% epicgameslauncher sits at 1%, doesnt connect.
checked with wireshark, no packets being sent out.

this is a epicgames issue, not a OS issue.

bumping with hope

after practically ruining my copy of windows 8.1 64bit, i just decided to upgrade to windows 10 64 bit, problem solved.

BUMP
in the hopes that at least one single dev or tech might have an answer.

@hredthel try installing visual studio 2015 from the Microsoft website on your own, it will install some updates with it, hopefully this might fix it

I would also suggest to try uninstalling your C++ redistributables, restarting your PC, and then downloading the ones directly from Microsoft’s website. After installing those, see if you receive the same error.

Thanks, I’ll give that a shot!

I upgraded to windows 10, it solved my issue.

I’m glad to hear that you resolved your issue, weandi, but hredthel shouldn’t be required to upgrade to Windows 10 to resolve this issue so I’ve converted your answer into a comment while we continue trying alternatives.

It works now! Thank you Matt Clark and Nightwacher.

I have had trouble installing Visual Studio 2015 for months (which I believe was the issue). I kept getting hung up on the installation’s restore point phase: a common issue for many people. No amount of HD space or reinstalling could fix it.

However when I installed the new Visual Studio 2017, both my windows 7 and visual studio updated and after a restart I am using UNREAL4. So far everything is running smooth! Thank you!

I did try reinstaling my c++ redist package after uninstalling and clearing the registry entries, but my pc kept telling me it was still installed. Most likely it was also installed on another drive, and since the 2017 visual studio installation seems to have fixed my problem I didn’t investigate further.