Editor windows randomly stop working

We’re having an issue in our team where various windows in our editors stop working, more or less at random. The problems started Friday afternoon and at first we thought it was down to a specific commit to our source control, which had introduced the errors. However, some people who were up-to-date did not have the errors and those who had the errors didn’t necessarily see all the problems. So eventually we all updated to the latest revision, which results in most of us having the errors, but not all of us.

To give an overview of what’s happening, here’s a list of the errors we’ve seen since this weirdness was introduced on Friday:

  • Blueprint Editor is completely blank. The top menu is there (the one with File, Edit, etc.) as well as the parent class reference and search field, but everything else is blank.
  • Content Browser is completely blank. The “Add New”, “Import”, etc. is there, but everything else is blank. Interestingly, if choosing Content Browser 2, 3 or 4 those will work.
  • Rotating the camera in the viewport is impossible. This was due to the mouse sensitive being set to 0 for some reason.

As said, it’s not everyone who gets these errors and they rarely all happen at once. After a period of debugging and internet searching we found a couple of methods that may fix the issue(s). These are:

  • Delete the Saved folder in the project library.
  • Delete the DefaultEditor.ini file from the Config folder.
  • Reset the layout from Window->Reset Layout.

It’s not given which of these fixes will work, but so far we’ve found that at least one of them will. The problem is that the issues will eventually return, which means we have to go through the fixes once more. It’s taking away quite a significant amount of time that we have to do this every once in a while and since our layouts get reset every time it happens, people can’t work with their preferred layouts for the editor. As said, the errors seem to come more or less at random, or at least we haven’t been able to figure out any consistent way of reproducing the issues. It seems that there might be a correlation between changing our layouts and getting the error(s), but it hasn’t been proved…

We’re running the Unreal Editor 4.13.1.

Hi HeinoJoe,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • What steps can I take to reproduce this on my end?
  • Do you see this occur in the binary version of the editor or only in your source build?
  • What specific changes have been made to the build?

Hi Adam.

I’m not at the office right now, so I can’t answer all of your questions. So far we’ve only experienced the issue in this one project, but none of us have tried reproducing it in a clean project either. We can try that though and get back to you with the results.

The real problem is that we don’t know how to reproduce this. As I wrote in my original post, it seems to happen randomly, but there was several of us who experienced the issue several times during the rest of our work day, after I made this post. I made the post in the hope that someone else might have experienced this or something like it and know of any reproduction steps - and possibly ways to fix it of course.

I’ll get back to you with the answers to your other questions tomorrow when I’m back at the office.

Thanks,
Heino

It is most likely related to this specific project. We haven’t tried testing this in a clean project though. Regarding your third question, do you mean that we should try to start Unreal through the normal launcher, open our project and then see if the problem shows up? We’ve had the error appear both when running the editor through our custom bat-file shortcut and when building and running through Visual Studio.

A new thing we’ve discovered today is that when the error happens it is changing various ini-files in the project’s Saved folder and exchanges all ‘.’-characters in decimal values with ‘,’-characters. So for instance the following line:

ContentBrowserTab1.VerticalSplitter.SlotSize0=0.250000

changes to:

ContentBrowserTab1.VerticalSplitter.SlotSize0=0,250000

It occasionally also happens with vector or float values in Blueprints.

We’re all using Scandinavian keyboard layouts, but we’ve been doing that throughout the production, so it must be something else that has decided it wants to change these values since Friday afternoon.

Yes, I mean if you install the launcher and the launcher version of the editor, do you see the same thing as you see in your source build?

After trying to revert various things that had been put into the project during Friday afternoon, we seem to have isolated the issue to be related to upgrading our GameAnalytics plugin to version 2.2.8. The plugin hadn’t caused issues before, but the time at which we made the upgrade seem to correspond with the time at which these issues started appearing. We tried to completely remove GameAnalytics from our project yesterday morning and no one experienced the issue for the rest of our work day. We still don’t know why it happens, but at least we (seem to) have found out what was causing it.