Download

Editor - WASD movement - Be able to set them up

Hi,

It seems that like in U3 we are unable to set the fly camera bindings.

Could you please add this? It’s really anoying for not qwerty keyboard or for left hand people :smiley:

It would be great to add those new mappins in the Editor settings screen.
it is linked to the “answers thread” here

If it is already implemented, could you please give me the way to do it?

Thanks,

I up because it’s so important for us :slight_smile:

Hi everyone,

If you go to the Edit>Editor Preferences>Keyboard Shortcuts tab and type in Viewport Navigation you should be able to set the keybindings from there. Have a great day!

This is working great now since the last version of UE. This was a great relief to be able to map that appropriatly.

Hi!

We can change in the editor but we can’t change in the game.
In the editor i can move with ZQSD but when I press “play” it’s a qwerty keyboard and only A and D works.

Sure it is a different settings. You must change the input binding in the project property panel under input tab.

Okay, thanks :slight_smile:

I use UE 4.10 but I can’t manage to use ZQSD keys for the flying mode in the editor viewport after clicking on PLAY
I’ve already modified the project settings for a correct key binding in the different axis (not necessary in my situation)
I’ve also changed the key mapping in the editor settings for the viewport navigation
My mapping seems to be correct (Z instead of W, Q instead of A…) but in play mode, moving still uses the “qwerty” style (WASD)

I’d prefer avoiding to use a character controller when testing, I just want to use the right AZERTY keys when playing my level

Is there a solution ?
thanks

did you change the basis or did you add an extra gamemode or playerblueprint??
if so the game from launch will use default character blueprint and gamemode? no matter what you changed…
correct me if im wrong on this…