Editor vs Build performance

Hi there,

I’m having significant performance differences between what I’m getting in the editor vs what I’m getting in build. I have tried disabling smooth framerate. I have tried setting a high maximum on smooth framerate. I’ve tried with lock framerate on and off. I’ve disabled monitor editor performance under scalability. I’m really at a loss. I’m getting a smooth 60-90fps in the editor and 18-40fps in the build. Whilst I’m currently learning all I can about performance optimisation it seems somewhat fruitless since its running fine in the editor anyway. I feel like the problem must lie elsewhere? I figure it wouldn’t hurt to ask if anyone could offer insight into what might be going on?

I’ve included some statistics below. I hope these help in isolating the issue.
Thanks.

I seem to have mostly resolved this issue. It’s not a perfect match but it’s much closer now. I’m using toggleable lights in my scene. I didn’t realise that a dynamic light with an intensity of 0 still calculates shadow information. Adding disable shadow casting as gotten the build to a mostly smooth 60fps. It doesn’t explain really why this behaviour wasn’t happening in the editor but a win is a win so i’ll take it.

I’m still stuck here. Why would I get amazing, beautiful, stutter free graphics in editor and then useless trash when I build it. I heard the editor automatic optimizes inside of the editor, how can I make it was doing in a build? Help please?

I’m still stuck here. Why would I get amazing, beautiful, stutter free graphics in editor and then useless trash when I build it. I heard the editor automatic optimizes inside of the editor, how can I make it was doing in a build? Help please?

I had the same problem. Here’s what helped me: First off, PIE(Play In Editor) automatically adjusts scalability settings to keep performance up. This was unknown to me, and is critical to understand. And you can turn it off!

Settings>Engine Scalability Settings>Monitor Editor Performance

You will see much closer framerates to what the build was showing (There wasn’t any way for me to mirror the performance of my editor to the performance of my build until this was turned off.)
With that turned off your profiling from PIE will be much more accurate so you can optimize your lights, foliage, and any other performance heavy things.

I have the same problem. 120 FPS in editor, 5 FPS after building with 4.22

I had some success with turning “framerate smoothening” off. I have had VR projects that work properly in a build. Just don’t necessarily know what was different. Also I can’t remember exactly what was said or where I read bit, but I think I recall reading it could be a tied to more than one texture on the floor) terrain. That is hearsay and speculation though.