Editor Utility widget Cannot print string

When I create a new project, using the Editor Utility Tools, I can print a string at first, but after using it for a long time or changing some values, I can’t print a string, even when I create a new widget or blueprint.

I tried a reboot, and the solution was to start a new project from scratch, but WHY is this happening
屏幕截图 2022-04-15 170039

If I clickedbutton_ Z, it won’t print

My thoughts would be that either the widget is consuming input (check widget settings) or another widget has been brought into the users focus as I believe you can only have one widget in focus at a time (Set User Focus).

1 Like

@new_chen1 Can you check your Output Log for this Print String Message?

If It’s there, then log messages must be turned off to appear on the screen. If that’s the case, then you can try “EnableAllScreenMessages” console command.

Hope this helps.

1 Like

the print string node was changed in ur engine ,default node has no world context Object in . u may check the engine source code to find out whats problem…

1 Like

The issue here is that this is being used with an Editor Utility Widget, thus, not at runtime (That’s also why the node has a context pin). I would suggest using the Editor Utility Widget itself for the text output.

1 Like

Thank you for your suggestions. I will try to solve the problem

Turn on real time viewport. When it’s off you won’t see messages printed to the screen.

You have to switch on show stats, Then the messages are visible on screen.

1 Like

This fixed it for me. Thanks.