Download

Editor Stuck at 75% loading?

I tried to open my project, compiles fine in VS. The project hangs at 75% and uses no CPU. I opened a different project and it starts up fine and very quick. How do I troubleshoot this?

Most of the work was done in blueprints, apart from simple base classes in c++. I am not creating object instances in the c++ base classes.

Launch the Editor process from Visual Studio to debug it.
At 75% stuff from PostEngineInit step is generated.

How do I launch the editor from VS? I tried googling this and found nothing.
EDIT: Nvm I see what you mean, hitting f5.

This is the last entry in the debug log. Not sure what this tells me.

‘UE4Editor.exe’ (Win32): Loaded ‘C:\UnrealProjectsC\RPGPrototype\Binaries\Win64\UE4Editor-RPGPrototype-0003.dll’. Symbols loaded.
The thread 0x3ff4 has exited with code 0 (0x0).
The thread 0x53d0 has exited with code 0 (0x0).
The thread 0x3288 has exited with code 0 (0x0).
The thread 0x539c has exited with code 0 (0x0).
The thread 0x5134 has exited with code 0 (0x0).

Do NOT use hot reloading, unless you are using Magic Nodes :wink:

Changing the structure of your GameFramework classes and compiling with Editor open will cause problems like these.

(Magic Node classes have a bypass against that).

Classic C++ programming in Unreal… just keep the editor closed while you are making changes to header files, really.


Btw, clean up your binaries with editor closed then recompile your solution to fix it.

Unfortunately I’m still getting the issue even after deleting binaries and recompiling. I think the project is corrupted…

*EDIT: Managed to get the project to open when finding and deleting the line…

static ConstructorHelpers::FObjectFinder Melee2hAxeAttackMontageObject(TEXT(“AnimMontage’/Game/Mannequin/Animations/ThirdPerson_2h_Axe_Attack.ThirdPerson_2h_Axe_Attack’”));