Editor sounds do not play while in PIE

Any sounds originating from the editor - such as previewing audio cues, compile sounds, PIE start/simulate (but not stop, as this is played after the PIE session is over), etc - are not audible while you are in PIE. I’m fairly certain that there isn’t anything wrong with my editor/project settings, as I’ve come across a few other people who have this same problem. It may very well be my system audio setup, but it was working fine at one point. Nothing relevant was logged from what I could see.

Hey `impulse,

Make sure the ‘Enable Sound’ option within your Editor Preferences is checked and you also have ‘Real Time Audio’ enabled within your viewport.

Sometimes a simple restart of your Editor can address audio issues like these. I did enter a bug report last week dealing with a related issue that you might find valuable for a workaround.

UE-36540

Let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley

I’ve tried out the workaround in the bug report you’ve linked, but to no avail. I’ve made sure that real time audio is also enabled.

Real time audio in the viewport works fine, it’s the previewing of sounds (via right-click and play on a sound cue) that doesn’t work while playing the game in the viewport. This also affects the start play-in-editor sound - and other similar ones like start simulate - since it’s played while you’re in-game.

Any audio that originates from the editor but not from the viewport/game itself seems to not play at all while you are in play-in-editor mode.

If you have the ‘Enable Sound’ option on, then the sounds while in game are going to take priority over the editor. When you are PIE (playing in editor) the content browser is not the focus and is expected not to take priority when playing sounds during PIE.

You need to make sure you restart the project if you have made changes to the ‘Enable Sound’ option for the changes to take effect.

Thanks,

Andrew H