Editor save dirty flag not updated in Windows task bar

I have my editor set to save on a successful compile, and when I compile/save * asterix is removed from UE4 tab at top of screen as it should be, however down in my Windows task bar * still shows as if dirty flag wasn’t cleared. In this example screen shot, it’s last tab BP_BaseDesk.

Also a related issue, my map on main window has not been saved but dirty flag in taskbar does not show asterix. But since this tab always shows name of project and not what map is open, I guess it’s not as big of a deal. Ideally it would show Project Name - Map Name - Dirty flag, not Project Name - Unreal Engine

I’m still using Windows 7 if it’s not obvious from screen shot.

Hey ,

I was able to reproduce this behavior, but only for a moment. It seems that taskbar only updates when tabs is given focus again. For example, if BP_BaseDesk is marked Dirty and then you click Saved, taskbar will continue showing it as dirty until you click anywhere in BP_BaseDesk tab.

Can you verify if this behavior is same for you?

Yes, clicking tab or graph will update it. My usual workflow is to minimize window and click play on map window which leaves it there.

Thanks . I entered this as a bug report for developers (UE-7391), though I’m not certain whether it’s a UE4 bug or a Windows bug. I’ll let you know when I hear back from developers with an update.