Download

Editor resource usage when idle

hi,

I’m aware that this has been brought up many times before, but the resource usage of the Unreal editor is still unpleasantly high.
I have tried switching to Unreal from Unity a couple of times because there are several good reasons for me to so so, but every time I gave it a try I eventually gave up because the editor is such a resource hog even when completely idle. I was just too unresponsive to use on my previous laptop (a mid 2012 macbook pro), but now I have a new one (late 2019 mbp, 16’’, 32 GB, AMD Radeon Pro 5500M 8 GB) and I was hoping that the new interface of UE5 would maybe address the fullscreen-repainting issue (see this video).

I must admit that I know very little about graphics optimising for GUI’s, but when comparing the behaviour of Unity vs. UE5 the difference is quite striking.

I made a screencast video of a scene I was building using the Unity default rendering pipeline, with Crest Ocean and volumetric fog added. When I start the game and walk around the water’s edge a bit, CPU and GPU usages go up of course, but CPU stayed below 100% (100% = 1 core from 8 total) and GPU was about 33%.
When enabling the Quartz debugger “flash screen updates” feature, it can be seen that only the area of the editor that displays the scene is updated.

I don’t have anything like that built in Unreal yet, so I tested it with the 3rd person template. Even when not running it - so the same situation in which Unity used barely any resources at all - Unreal editor takes 170% CPU and something between 20 and 60% of GPU capacity. It’s striking that when I play that template scene, the usage does not change much at all: it stays around 170% CPU and 20-60%GPU. The quartz debugger shows, just like in Chilton Webb’s video of 4 years ago, that Unreal editor v.5 is still continuously updating the whole screen.

It is as if Unreal is running the editor UI in the same graphics mode as in which it runs the game.

Other than on my 2012 machine, the editor is still responsive. But it is still just rather unpleasant to have it heating up like that, with fans spinning up as if it’s about to lift off, for no good reason at all.
I’m also concerned that it will shorten the machine’s life.
In Unity, I only get that when baking the global light map, and then I just leave it alone for a while until it is done.

I really hope you can address this issue. It really would be too bad if this would again keep me (and many others, judging by the number of posts about this same issue going back to at least 2015) from switching to Unreal, there are so many good reasons for that.

Here’s the screen video I made of the comparison

By default UE comes with lots of things turned on that if you wish performance you’ll need to disable:
Viewport > Turn Off Realtime (CTRL+R) .
Menu Edit > Editor Preferences > Turn on Show Frame Rate and Memory AND Use Less CPU when in background
Console Command Window > Type: t.MaxFPS 60 (to block EditorUI running at 120fps or more)

You can also change Engine Scalability Settings to Low or Normal while working and don’t need it to be running in Cinematic or Epic settings all the time.