Editor popup windows appear off screen when using different resolution screens

I am running into the same issue with a similar monitor set-up. I can snap editor Windows like Details and Content Browser using windows key + arrow key but some pop-ups like FBX importer are stuck off-screen.

I have a 4k monitor and a 2k monitor. My main editor is in my 4k monitor full screen, and I have my other windows on my 2k monitor.

The problem happens with all types of editor windows, but here’s a specific example.

  • When I’m editing Engine-Collision settings (on my 2k monitor), when I click to edit a preset, the popup appears somewhere off screen, and I have to use [Win] + [Arrow Key] to move the window into view.
  • I believe this is happening because it is centering the popup window as if this was a 4k screen, which is where my main window is.
  • It should be centering the popup based on the resolution of whatever screen the calling window is in.

Example:

193646-ue_answerpic30a.png

Hello BenVlodgi and h34vy,

I have a few questions about this issue to narrow it down and assist with reproducing it.

  1. Is this issue specific to 4.17 or does it happen with other versions of the editor?
  2. What version of Windows are you using?
  3. As this is related to a lot of issues when it comes to varying resolutions, are you using the window scaling from the Windows display settings? If so, what % is it set to on your 4k monitor?
  4. What specific resolutions are you using? Exact numbers please.
  • This was happening with previous versions.
  • Windows 10
  • 1920x1080 for the 2k monitors (100% scaling)
  • 3840x2160 for the 4k (125% scaling)
  1. In 4.9.2 the FBX importer was visible on my third monitor, although I noticed I can’t windows key + arrow key snap this dialog
  2. Windows 10
  3. & 4. display 1: 1920x1080, display 3 (main, 150%): 3840x2160, display 2: 1080x1920

I am also experiencing this bug. It’s making the editor almost unusable.

Does anyone in this thread have a good workaround? The WindowsKey + arrow key trick is not working for me. Every time I open a modal dialog such as “open level” I can no longer work because it appears off screen and I have to force the editor to quit and then reset the UI.

For folks who are struggling with this I found that by disabling scaling on the HD monitor and lowering the resolution at the system level it at least prevents the dialogs from appearing off screen. It’s not ideal of course because this display now becomes blurry and low res which defeats the purpose of having an HD monitor but it does work.

My workaround has been to squint and read the error in the preview pop-up from the task bar, close the error, and hopefully avoid another error message :slight_smile:

Hi, I’m also experiencing this bug since using engine version 4.17

My setup: Windows 10

  • main monitor @ 3840 x 2160 (150% text scaling in windows)
  • second monitor @ 1920 x 1080
  • third monitor @ 1920 x 1080

The workaround I found is not very user friendly but it works:
If an editor window pops up off screen, and you cannot access it using ALT + TAB, open “Display settings” by right clicking the windows 10 desktop.
There, change the resolution of the 4K monitor to a lower one and click “apply”
→ the window that popped up off-screen now appears (mostly save prompt windows in my case)
→ Then you can set the resolution back to 4K.

Hi - update: since a while I am no longer experiencing this problem.

Hi, just ran into this problem myself after the BP ‘Viewport’ tab disappeared on me, so thought I’d post in case this helps someone. I have 2x 4k and 1x 1080p screens, the fix here was to switch the 4k monitors to 100% scaling, reattach the Viewport tab to the BP editor and then set the scaling back to 150%.

Hi, this simple trick worked for me, hope it helps:

Put your mouse over UE4 in the taskbar => Right click on the off-screen window tab => Click Move => then move it with your keyboard’s arrows.

2 Likes

This helped me very much

Worked for me to. Sometimes you have to move your mouse after pressing the arrow keys… but definitely gets off screen windows back on my dual monitor set up.

1 Like

Similar situation - 4K main monitor, a 1920x1080 monitor to the left of it, a 2560x1440 monitor to the right. New windows would open as shown in the OP’s diagram - off the bottom right of the rightmost monitor.

Two solutions I’ve been using:

  1. dinasorZ’s “Move” but I use Alt-Space M then arrow left until it comes into view (saving having to select the window as it’s already the active window after opening it), or

  2. In Editor preferences, specify to open in the Window in the Main Window. From there it will disappear like before if you drag it to the monitor it was previously appearing off the right of. However if you undock it first in the main window (just by dragging its tab downwards), then you can drag it over ok. I have no issues dragging it from the docked position to my left hand monitor though.

and a third that will be the easiest that works generally in Windows, but I’ll have to wait until it happens next to be sure for UE:

  1. Shift-Windows → or Shift-Windows ← immediately after the windows opens off scree. This will move it between monitors.

1 Like

helps… crazy this still happens in UE5

1 Like

Thanks for the general Windows Alt + spacebar hotkey!

1 Like