Editor menu items "flickers"

Hi, I noticed that when I browse nested menu tabs in editor, expanding the sub-menus occasionally causes a duplicate one to repeatedly, and rapidly, appear and disappear at the corner of the parent menu tab. A screenshot of such instant is taken as shown below.


Note that this never happened when I was using the downloaded 4.7 binary release until recently when I switched to compiling the engine from source.

Thank you for attention.

Hello Lyan,

Would it be possible for you to try downloading 4.9 from the Epic Games Launcher to see if the issue occurs there as well? I haven’t seen this issue as of yet using this version of the engine but I’ll keep an eye out in the meantime.

sure, I will try it later

Just tried, I confirm that the problem persists with the 4.9 release downloaded through the Epic Games Launcher.

Thank you for testing that for me. Could you provide me with your DxDiag as the issue may be hardware related. There have been reports of this kind of issue before but they were symptoms of another problem. The previous reports were related to graphics card switching on laptops.

link text

Attached is my dxdiag.

That could be cause of my problem too since I’m also using a laptop with a dedicated gpu along with the integrated intel one.

In fact, I can’t get dxdiag to show information of my dedicated gpu, it is a GT650M from Nvidia, please see the link to Nvidia for more details about the card.

link text

That could be the issue. Could you check your Nvidia Optimus settings and make sure that the Nvidia card is being switched to when UE4 is opened? If not, that may be the issue. In that case, you should be able to make a custom profile to have it do so when UE4-Editor.exe opens.

It was previously with auto-select mode so I could not tell which card was used with UE4 opened, but setting to switch to the Nvidia card manually still doesn’t solve the problem :frowning:

Hello Lyan,

I was able to get a hold of a laptop with similar settings to yours, which used integrated Intel graphics but switched to an Nvidia GPU when using the Editor. I was able to reproduce it with this so it must be either related to the GPU switching itself or just the M series of Nvidia GPUs. Either way, I’ve put a bug in for the issue under the number UE-20675.

Have a nice day!

thank you!

I fixed the glitches for myself by forcing “Integrated graphics” on the editor in my NVIDIA Control Panel. Executable path: “C:\Program Files\Epic Games\UE_4.18\Engine\Binaries\Win64\UE4Editor.exe”

It works for now, but may give performance issues when testing larger games in-editor because it’s running on a less powerful GPU. I haven’t stress-tested this yet but count on it.

Same issue here, fixed as Kas Slim said… but also running on a less powerful GPU

In case it can help, I am using ue4.18.1 in a laptop MSI GE72 2QD with GeForce GTX 960M, driver version 377.19 under Windows 7 Ultimate 64-bit (sp1)