Editor Memory Leak?

I don’t know if this is specific to the crashes that i’ve made other threads about, but it seems that once I enabled memory monitoring, that I load my level at 1.7gb and some sort of crash happens just after 3gb. Is there a way to reduce the amount of memory being used or is this a bug? I have a 16GB ram macbook pro that otherwise runs everything fine but I can’t figure out why the editor (not the actual gam) builds up memory usage so quickly?

Any updates on this? It’s a pretty consistent issue, though can at the least I can now make controlled exists and re-loads of the game by keeping an eye on the memory usage.

Hey ,

We are unable to reproduce this on Mac, but we recently had a memory leak associated with users leaving the Project Settings window open. Can you ensure that that isn’t open?

3GB is not a lot of memory usage for a UE4 project, so I suspect the crash is not being caused by the memory usage. The level itself could be corrupt or other processes on your mac could be taking up a lot of memory. Could you check your activity monitor?

The project settings window is not required to be open for this issue to occur and I don’t use it much other than to create new inputs. The screenshots were taken a few moments before the crash log that I just submitted. Unfortunately it won’t fit in these input fields. As you can see the level is empty except for the blueprint which spawns other actors into place.


Try migrating this blueprint and its associated files to a blank project and add to an empty level. If the crash occurs, please provide this test as a link to a zipped project on Dropbox, Google drive etc. If you do not want to post it publicly, you can send the link to me on our .

Hi ,

Since we have not heard back from you in a while, we are marking this post “resolved” for tracking purposes. However, if you are still experiencing crashes with memory monitoring enabled on your Mac, please respond with the requested information and test project and we will continue to investigate.



Please keep this ticket open. I haven’t been able to reproduce it when migrating files yet, but it still crashes with regular frequency.

Since we cannot replicate the error at this time there is nothing more we can do with this ticket. However, if you can provide a way for us to reproduce the crash, either with a project or merely with a list of precise repro steps, simply post that information here and it will reopen this ticket automatically.


How can I send you a project link via pm/email if I don’t want to post the project publicly online?

I migrated over the project to a blank project, and I removed all but the necessary files to run in the editor - it is now at about 40mb. The project starts with lower memory and seems to take longer to crash, but it continues to crash at around 3500-4000 mb, though it seems to take longer to trigger it.

For the life of me I cannot figure out where the crash or surge in memory comes from.


Hi ,

Please send a link to your zipped file posted on Dropbox, Google Drive, etc. to me in a Private Message on our . -This will go to me only and not posted publicly. We have done this in the past with similar, problem issues.

Much appreciated! i just sent you the link on the .

Hi ,

The project you sent requires 4 plugins that we do not have access to and may be the cause of the crash. In which case you would need to contact: ue4@lowentry.com for support.

However, if you can reproduce this behavior in a project that does not require 3rd party plugins, please send us that project and we will continue to investigate the issue.



I will give that a try and let you know what happens. Is it possible for plugins to corrupt or crash the editor?

My understanding is that plugins are not in effect until the game is compiled or running?

I’m still working on this. I tried one by removing a significant amount of the plugins, and it seemingly resolved it, so I created a new version of it with his plugins in. But while creating the new version, I slimmed down the project, removing most meshes and actors that I thought weren’t relevant. I ended up with a version that I cannot crash.

I created another version to send to LE, but with the plugin active, and a slimmed down the project by removing a bunch of actors I thought were irrelevant. That also produced a version that I couldn’t crash.

I imagine that in both cases I may have changed a BP that was contributing to the issue?

I will keep working on trying to find a version that still crashes with the game in without the plugins. The main issue with removing the plugin is that the BPs rely heavily upon the filesystem and json libraries that the plugins create, and much of it is interwoven, so removing the library requires a bit of massaging of other BPs

It’s not likely but I wouldn’t rule them out entirely. In any event, if you can reproduce this without any third person plugins present and can provide us a copy of the project it will aid us immensely to pinpoint the cause of the crash/memory leak.

I tried this again tonight, but removing the LE plugins require me to remove such a significant amount of the project that it isn’t at all the same project anymore, with entire libraries essentially useless.

At this point I don’t know if it is because I’ve severed so many blueprints, or if it because I removed the plugins.

Is there any way to point myself in the right direction using the logs that the error generates? Surely they can point me towards something section of my blueprints?

The bug you’ve reported for project Blueprint_kTesting (UE-38772) has been shown fixed for UE4.15. If you want to test this, open a COPY of your project in UE4.15Preview (do not over-write your original.) In fact, you may want to make a back-up of your Unreal Projects folder altogether, if you have not already.

As far as the project UE4-DebugProjectJan18 almost all reported crashes start with:


…which would likely be caused by a folder or asset in a directory to have too many characters or an invalid character. The name “UE4-DebugProjectJan18” seems a little long but may not be the culprit.

Check your assets in the Content folder and subfolders of the Content folder in your Project folder to make sure neither your assets or their containing folders have more than 21 characters and that those characters are not invalid (ie… : ? ; “” etc.)

If you do not find any, try renaming your project to something shorter or migrating you files to a project with a shorter name.

Thank you, this all helps. I will try out the 4.15 preview! Fortunately, backups are the one thing I have going well. I’ll keep the name length in mind when creating these.

Thank you for the extra information.

As for the time being, I cannot even launch the preview without a crash. I’ll keep an eye on the thread/response.

I’ve responded to that thread and will work with you there to get the UE4.15 Preview running. Please wait until you are able to open the 4.15 Preview before updating this thread (for tracking purposes) -Thanks!