Editor loads old versions of assets

Hello, it seems that I encounter bug when reopening project. It happens to some assets (2 for sure). For example Rifle (SK from shooter example) keeps same socket name, even if I change it, after reopening project it is still the same.
Same issue with my character blueprint… after reopening the mesh component is set to none.

What’s going on guys?

Hey matmow-

Are you referring to the name of the asset not being saved after changing it or does the the asset’s functionality revert to a previously saved version? Also, which version of the engine are you using? Are you building the engine from GitHub source or are you running the binary version through the launcher?


Doug Wilson

I fixed all references and saved assets after changes.
The version I use is 4.6.1, not from github

Hey matmow-

Do the names of the assets still revert back when reopening the project? Does the same behavior occur if you create assets in a new project and try to reopen it after changing them? Please provide details for what you mean by the editor loading older versions of assets.

It doesn’t happen to all assets, only a few (2 known). I mean changes made inside blueprints - for example after loading a project my character mesh is cleared. I set it again then save (no problems here). After reloading projects the mesh is unset again

If you make a copy of the blueprint after adding the mesh and fixing other references, does the copy appear with an empty mesh upon restarting as well?

So I made a copy, replaced references (manually, there was another error on automatic - I can’t remember which one) and still same issue… :confused:

Also tried creating new blueprint with the same settings and nodes, again the same… Taking stuff to parent class helped, but it isn’t the way I like

Hey matmow-

I’m having difficulty reproducing the issue on my machine. I’ve created a blueprint with some variables and components. After compiling and setting the defaults I saved and closed the project. Upon reopening it the values were still set as they had been. Could you send a copy of the assets that you’re having issues with or an empty project that demonstrates the problem you’re having?

Hi matmow,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.