Editor launch freeze after upgrade


I have changed the version of a game from 4.8.3 to 4.10.1. After doing so, I was unable to launch the project - loading stuck at 72%. Perhaps I have missed something, but does anyone know how can I proceed past this point?


Tried the following (based on suggestions found on this answerhub):

  • Verified the 4.10.1 installation → Downloaded something, but nothing changed in regards to defect above
  • Created a new project in 4.10.1 → Launches normally
  • Launch from the Visual Studio 2015 | Development Win32 → Fatal error (see image below)
  • Launch from the Visual Studio 2015 | Development Win64 → Keeps launching forever, killed the process after several minutes
  • Launch from the Visual Studio 2015 | DevelopmentEditor Win64 → “Failed to open descriptor file 'ProjectName.uproject”


Hey -

Did you upgrade the project straight from 4.8 to 4.10? If so can you attempt to upgrade through each version (4.8 → 4.9 → 4.10) and confirm that the project opens with each version. Do you have the same issue with other projects or is it only one that is having problems opening?

Hello , thank you for the response.

I’ve attempted upgrading through 4.9.2 and it seems that it is already not working there. This time, after launching the project, editor is crashing before fully launched and I am left with a stacktrace I don’t understand (submitted to Epic). Following error is outlined in the crash report:

“Assertion failed: !HasAnyFlags(RF_NeedLoad|RF_NeedPostLoad) [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.9\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectL”

Additionally, I tried to compile the project in both Development Win64 as well as DevelopmentEditor Win64 configurations. DevelopmentEditor compiled succesfully, however, Development finished with following compilation errors:

1>C:\Some Folders\Project Name Workspace\ProjectName\Intermediate\Build\Win64\UE4\Inc\ProjectName\ProjectName.generated.cpp(266): error C3861: ‘FindExistingEnumIfHotReload’: identifier not found

1>C:\Some Folders\Project Name Workspace\ProjectName\Intermediate\Build\Win64\UE4\Inc\ProjectName\ProjectName.generated.cpp(1332): error C2039: ‘SetPackageFlags’ : is not a member of ‘UPackage’

Regarding the assertion - it is strange that anything points to a D drive, which I don’t use for any Unreal Engine related files.

Project launches successfully when switched back to 4.8.3

Do you have the same issue in a new project created in 4.8 that you upgrade to either 4.9 or 4.10? Can you right click on the .uproject and Generate Visual Studio project files? After this build the .sln in Development Editor Win64. If that completes successfully can you then open the project (in 4.9 or 4.10)? If you are still having problems opening the project after this can you send the project to me to test directly? For privacy, if you’re able upload the project to dropbox you can then send me a PM on the forums with a download link.

I have tried to replicate this issue in a new project, but everything seems to be working there. I also tried the “Generate Visual Studio project files” command and little progress was made → In 4.9 editor launches. Unfortunately, when loading my level on 4.9, or opening the project on 4.10, game crashes.

I am currently uplading the project to dropbox and will PM you on the forums with a download link and some further details. Thank you for the continued support on this issue.

Hey -

I’ve tired to open the project you sent on the forums but the project won’t open through the .uprjoect and I’m getting compile errors when trying to build or run the project in debug mode through Visual Studio. I will continue to look into but can you confirm that the project compiles successfully after upgrading to 4.10?

Hello ,

I’ve done the following:

  1. Downloaded the project I sent to you to have an exact version
  2. Right-clicked on the uproject file to upgrade directly to 4.10
  3. Generated Visual Studio files
  4. Launched the .sln file in VS2015
  5. Compiled the project in DebugGame Editor as well as Development Editor modes

Both of the above compilations succeeded. Unfortunately, Editor still doesn’t launch.

Hey -

I was able to get the project to compile after removing the -Only property from the project folder. Attempting to run the project through VS debug mode revealed that the editor is getting stuck at waiting for an event that doesn’t seem to be occurring.

Hello ,

I launched the project through VS debug mode. Unfortunately I am unable to determine what event is the editor waiting for as I am not really familiar with the exact launching process. I had a look at the debug console, and it seems that nothing is happening after I am thrown with several warnings (not errors or any events that you’ve mentioned). Do I have to resolve those warnings before the upgrade or is the cause of this completely elsewhere and I am missing something?

See the attached file for a fragment of debug console I am reviewing.


Hey -

I don’t have any updates at the moment however I’ve reached out to other developers about this loading freeze and will update you once we are able to find more information about what may be causing this problem.

Hey -

I’ve done some additional testing but have not found the cause of the project not loading in 4.10. Have you had this occur with any other projects? If possible, can you try converting the 4.9 project again and let me know if the new copy of the 4.10 version still has the same issue?

Hello ,

I tried to find the cause of the problem myself, both in 4.9 as well as new 4.10.2. Unfortunately the issue still stands as nothing has been resolved by the partial/full upgrade to new versions.

I have not worked on any other projects so obviously this didn’t occur anywhere else. I only tested new projects created specially for the purpose of upgrade test - they worked as supposed to.

Do you still have a copy of the 4.8.3 version of this project? If so can you let me know if it still opens in 4.8.3 editor? Also, can you send a copy of the 4.8.3 project as you did with the other version of the project? Was the other projects you tested created in 4.8 like the original project?

Hello ,

I think I may have created a slight confusion around the versions so allow me to clarify. The project I sent through forum was created in version 4.8 and I sent it exactly in the same version. When launched, editor is opening and it seems that nothing is wrong. Unfortunately, problems start once you try to upgrade this project to different versions (4.9 or 4.10) - editor simply doesn’t launch or a stacktrace is thrown (as I described in above posts). I have sent the project in version 4.8 so that you would be able to reproduce the upgrade procedure by yourself.

When I mentioned other projects, I have simple created a brand new project in version 4.8. Upgrade to other versions worked without any trouble.

Hey -

I was able to narrow the issue down to the Top Down Character blueprint in the Content /TopDown/Blueprints folder of the project. Removing this asset caused other errors (since the blueprint no longer existed) but it allowed the project to open in 4.10. You may want to use a previous version of this blueprint if available.