Editor Lag (4.12.5)

Hey!

Ever since I upgraded to 4.12.5 my editor has been lagging, for example: When I want to create a folder it basicly looks like this: http://prntscr.com/btrgx5 , it takes like 5 seconds to select an object in the scene etc…
It was working fine before, not really sure what happened… :confused:
please help :slight_smile:

Same problem here: fast viewport, editor unusable at all .
hardware: Dell 7559 i7 16GB RAM, gtx 960M. I’ve the right settings in Nvidia control panel. I also disabled notifications in windows 10 pro. I’m not running any software mentioned in the conflict list here A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums.

I also have this problem, though I found if I unplug my monitor connected with display port, it doesn’t lag any more.

I don’t have any monitor plugged, anyway I got the 4.11 and the issue seems to be solved.
So it looks like a 4.12 bug… hope will be solved soon!

Same issue here.

I have made a video that shows the issue right after renaming an asset in content browser:

https://saibertek.systems/aiadmin/til/ue4/4125LagEditorBug.rar

I also do work with a monitor on DP, but I can’t work without it so disconnecting it is not an option.

Hope you’ll find out what’s causing it.

https://saibertek.systems/aiadmin/til/ue4/ue4lockups_sounds.rar

This might give you a further lead - disconnecting my DP monitor didn’t do anything, but yesterday I noticed a short “beep” coming from my speakers whenever the editor unfroze.

In fact, there are two noises - one is an “eeeeeeeeek” that lasts for about three seconds, which is the “lockup phase” if you will, which is then ended by the “beep” sound.

On this recording, you can hear three of the lockups happening - one at timestamp 00:02, the second one at 00:10, and the third one at 00.24.

Sorry for all the static - also make sure to amplify the volume massively so you can hear what’s happening.

It was very hard to catch with my microphone, so this was the best I could do.

P.S.:

I’ve tracked down the issue now - it is definitely caused by my external SSD.

NOT a UE4 problem.

Are you running UE from an external SSD drive as well, by any chance?

Cheers