Editor is not highlighting menu properly where cursor is on 4K monitor

Look at screenshot and see where cursor is and what is highlighted. It is impossible to select “File Media Source”. Basically the problem happens if a sub-menu does not fit on the screen. That black bar at the bottom is my task bar.

My set up: Windows, 4K monitor, 3840x2160

I run editor as: “C:\Program Files (x86)\Epic Games\4.15\Engine\Binaries\Win64\UE4Editor.exe” -enablehighdpi

Hello Flash7,

Are you using the widget reflector or scale UI in windows 10 along with the - enablehighdpi?

No, no widget reflector and scaling UI in windows 10

Are you altering the scale of the editor in any way? If so, could you elaborate on how I could reproduce this issue on our end?

I do not touch scale in any way.
Are you trying to reproduce it on 4K monitor?

I ran a couple of tests on my end that included a 4k monitor. However, I was not able to reproduce this issue with -enablehighdpi only. Could you provide your dxdiag so that I could ensure that there are no other dpi settings that have been altered on our machine?

Rudy, I think it is related to my other problem:

Actually, I do have DPI set in Windows to 150%, otherwise, all text and icons in Windows are a way too small. At any case, -enablehighdpi works only if Windows DPI set above 100 (just for experiment, I tried at 100, but then editor does not scale fonts).

I tried to reproduce the issue on an empty project (4.15), but it all seems to work. The project I’m working is an upgrade from 4.12 → 4.13 → 4.14 → 4.15

gxdiag

I found something interesting:
The project that is giving a problem has “About Unreal Editor” looking like this:

127651-2017-02-24+12_38_22-about+unreal+editor.png

while from a clean project it is looking like this:

I run the editor, and then select a project.

Hello Flash7,

As this issue seems closely related to another issue that you’ve reported, I’ll be closing this one as a duplicate to avoid splitting information any further. Please refer to the other post for continued support: