Editor Hits Breakpoint, kernelbase.pdb not loaded

Hi, i have been working on a project for a couple of weeks now and a couple of hours ago i started getting some problems when i compiled the game using visual studio 2013 and then tried to play the game.

Each time when i press the play button i get thrown out to visual studio which complains that the “kernelbase.pdb” was not loaded. However i can then press the continue button and the game will continue just fine, i can also use the simulate button and simulate the game without the game hitting a breakpoint. If i close down visual studio and just run the project i can play without any problems.

I found this page, but i cant seem to find the “BuildConfiguration.cs” to change around the settings.

This is the last part of the output in visual studio

D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.0\Engine\Source\Runtime\Engine\Private\BlueprintGeneratedClass.cpp(177): Ensure condition failed: TimelineTemplate != NULL

UE4Editor.exe has triggered a breakpoint.

Has anyone had the same problem or does anyone have a solution to my problem?

Still can’t figure out why the breakpoint keeps activating. Do anyone got any suggestions that i can try?
I’m trying to find the BuildConfiguration.cs but i cant seem to find it anywhere, anyone know where it is?

I tested activating the “Tools > Options > Debugging > Symbols > Microsoft Symbol Servers” and tried to run the editor with that option on but it gets stuck when it’s trying to load symbols for the rasapi32.dll from the Microsoft Symbol Servers, after roughly 15-20 minutes i canceled as it seemed nothing was happening.

It looks not like a breakpoint, more like an assert. You could check out the unreal source from the tag you are using (I assume 4.0.2) and look in the the source when VS stops.

Alright, made some progress. I checked out the source code like plucked suggested and found that the editor stops at

// Not fatal if NULL, but shouldn't happen		
if(!ensure(TimelineTemplate != NULL))

that is in the /4.0.2-release/Engine/Source/Runtime/Engine/Private/BlueprintGeneratedClass.cpp.

So after that i started checking my blueprints to see if there was something wrong with them or to see if there was a timeline in any of them for some reason as i have not added any timelines myself.
After checking all the blueprints in my project i found that when opening the components tab of the MyCharacter blueprint of the FPS template caused the editor to complain. But i can press continue and after another break i can see the components tab of the blueprint.

On the blueprint i have a charactermovement, a root capsule component, an arrow component, empty mesh component, FPSCameracomponent and a capsule component. Anyone know if these could be causing the problem or why the TimelineTemplate causes problems?

Edit: Also, the same thing happends if i try to add, remove or edit any components in the blueprint.

Turned out that i needed to recompile the Blueprint “MyCharacter” in order to make it stop causing me problems.