Editor hangs on startup

just downloaded, installed the redist stuff

opened the editor and it hangs on
Compiling Shaders: WorldGridMaterial…

Hi Mick, what are your PC specs? Also, did you move the installed Rocket folder or a created project before launching up? Sounds like it can’t find the precompiled shaders we include for the engine and all projects.

specs are just above the minimum
didnt move anything
i left it for half an hour, it got past the shaders and onto the next thing.
however it seems to have just closed itself now

opened it again and i get the new project screen with a popup saying compiling shaders

succsess!! opened the sidescroller blueprint

still says compiling shaders though

please bump up the minimum specs for ue4
it runs but is so slow its unuseable

is there are some command line options to compile shaders, like in UE3?

its been sitting there for an hour now still with the compiling shaders popup

Hi Mick, you should never encounter long shader compile times as we’ve already precompiled them for you. We do know a couple scenarios that could trigger this: renaming or moving your Rocket or SampleGame directory, or not running as an admin. Do any of these apply? Are you seeing this when only launching the editor, creating projects, opening sample projects, all the above?

Also, one thing we haven’t tried out yet is if certain antiviruses block access to your C:\ProgramData directory. What antivirus are you using?

As for low framerate once you’ve launched - we understand that using beta software can be frustrating, but we really need specifics in order to make sure we address any issues. We do extensive testing in house, but we of course can’t hit all hardware combinations and really rely on these kinds of reports to direct us. Could you list your CPU/GPU model, RAM amount, and OS?


running as admin, nothing moved
all of the above
i recently removed my antivirus as it ran out, so no issues there

just by sticking with it, i tried out sidescroller, then third person
all the time i get the compiling shaders popup, execpt…
i ran the third person in viewport and noticed txt on the ‘hud’ saying compiling shaders (or similar) with a number in brackets slowly counting down from something like 1700. all the time getting a framerate between 0 and 4. i let it run down to 0 (maybe 5-10 minutes) and voila! suddenly the game ran smoothly 60 and above fps.
i exited the game back to the editor and everything seemed to run ok.

windows 7 (french)
packard bell ipower gx
intel core 2 duo p7450
nvidia geforce gtx 260m
4gb ram

i know its right at the limit but its all i have. one of the udk forum modorators (jeff) has or had the exact same model if you need someone closer to test with.

let me know if you need more info

Hi Mick, we did a bit of digging around (and asking around for a similar spec, unfortunately these systems aren’t produced anymore) and found that some DX10 GPUs are having problems recognizing the included precompiled shaders. We’ve gone ahead and fixed that, so you shouldn’t encounter it again in the August beta release.

One thing to note - you’ll only need to encounter this headache once per Sample. Once you’ve loaded it up, the shaders are compiled and you’re good to go. Usually, this lasts about 15 min on a min spec system. But it’s unfortunately quite a bit longer for you because your processor is a good bit below that.

Thanks for reporting this issue, was a biggie and we very much don’t want to include this kind of headache in our betas.