Editor hangs for 30 seconds when I play or undo

Since I upgraded to 4.22 about a week ago, my project will hang for 30 seconds every time I test play it. I’ve tried it on multiple maps, one which is quite large, and the other which is very small. Both have the same issue. It also occurs sometimes when I undo and action, or make an adjustment in the material editor.

Here are things I’ve tried that haven’t worked. Before I started really working in the project, I followed the instructions to enable raytracing (ie adding -dx12 to shortcut properties), then discovered I couldn’t use the feature on my card. Once I noticed the issue, I reversed the steps, including disabling raytracing and deleting the shortcut with the “-dx12” adjustment. Issue persisted. I also decided not to install the Substance plugin with the upgrade, since it isn’t compatible yet, and also since I only used it for a single material, and have since decided not to use it at all. I thought perhaps the Substance materials were causing issues somehow, so I removed everything in that folder, and replaced the material that originally used it. Still hanging.

I’ve googled the issue, and haven’t found any information about it, or anyone else having the same problem. As you can imagine, it’s really killing my workflow. When I’m doing a lot of level testing, every two times I hit “Play” is a solid minute of waiting, so a lot of time is wasted. If anyone can help me resolve the issue, it’d be greatly appreciated!

Can anyone help me with this? It’s been 20 days, and the problem persists. This project is almost unusable if I can’t fix it. I tried building the DDC by recommendation of another post, but that did not fix it. I really need to get this solved so I can continue working on this project. There are a lot of people waiting on me to send them an updated demo, and I can hardly make any progress because almost half of the time is spent staring at the engine waiting for it to respond.

Hello,
I have done some reading on this.

  • try freeing space on your hard drive if you’re running a bit low
  • if you use cast to on event tick, try unplugging it see if that helps
  • think back to what have you been doing when this first started, maybe go over some code in search of a infinite loop, but I think the engine would pop out a warning about this → Quote from another post: “I had a component which, when it was created, spawned in an actor with the component that spawned it. It caused an infinite loop. If I started it in a different map the problem carried over because the default Game Mode I had also, eventually, ended up calling that component through the player character I had set up. Thanks for your help.
  • might be a good idea to look inside your logs (x:\Users\User\Documents\Unreal Projects\ProjectName\Saved\Logs)
  • you could try setting the quality to low, but I bet you have already tried that
  • if you use Behavior Tree have a look in there too, maybe something is being spammed
  • does this happen with every project or just this one?

If I can come up with anything else I will comment again.

Thank you for the suggestions. I’ll try some of them out. Honestly, I think it’s something with the editor itself, because the project worked flawlessly before I updated versions. And not only that, but the editor itself hangs for about 30 seconds every time I load the main level, and when I’m editing materials it will do it randomly. It sucks because I was really excited for the update, and I’m trying to get the ball rolling on this game, but as soon as I upgraded it started acting up. If it’s not the DDC, then I have no idea what else to try.

Let me know is any of the above worked for you… if not we’ll just keep digging.

I really appreciate your help, Don. I’ve only tried a few things so far. For starters, I made a duplicate of the level that’s giving me trouble, and I deleted every blueprint in the level, and the issue persisted. I forgot to mention that last week I made a game in a week for a game jam, and didn’t have any issues whatsoever, so I know it’s particular to this project. There’s also another level within this project that runs fine usually. But for some reason, the main level causes all sorts of horrendous lag. I’m taking this a step at a time, and I’ll share whatever I discover with you. I checked the log file, and found a few errors. I tried a solution that worked for someone else who had those errors, which was to delete the “Common” folder that I believe holds the DDC. It’s currently rebuilding on its own, but there’s still a solid 30 second pause when I test play. Here are the errors I was talking about:

Log file open, 04/30/19 00:48:17
LogWindows: Failed to load ‘aqProf.dll’ (GetLastError=126)
LogWindows: File ‘aqProf.dll’ does not exist
LogWindows: Failed to load ‘VtuneApi.dll’ (GetLastError=126)
LogWindows: File ‘VtuneApi.dll’ does not exist
LogWindows: Failed to load ‘VtuneApi32e.dll’ (GetLastError=126)
LogWindows: File ‘VtuneApi32e.dll’ does not exist
LogConsoleResponse: Display: Failed to find resolution value strings in scalability ini. Falling back to default.
LogInit: Display: Running engine for game: CLOWN
LogPakFile: Registered encryption key ‘00000000000000000000000000000000’: 0 pak files mounted, 0 remain pending
LogPlatformFile: Not using cached read wrapper
LogTaskGraph: Started task graph with 5 named threads and 14 total threads with 3 sets of task threads.
LogStats: Stats thread started at 0.232896
LogD3D11RHI: Loaded GFSDK_Aftermath_Lib.x64.dll
LogICUInternationalization: ICU TimeZone Detection - Raw Offset: -8:00, Platform Override: ‘’

Any chance this could be the source of the issue?

I’m having the same issue and look forward to other ideas to fix it. 4.21 was rock solid for me. 4.22 has been nothing but heartache so far.

If there a chance you could package your project? I mean the files from
X:\Users\YourUserName\Documents\Unreal Projects\ProjectName\

I could then download it and see if I get the same problem. If you decide to do it please don’t include anything I can add myself like starter content/AnimStarterPack so it doesn’t end up being a massive file?
I really want to find out what’s causing this since so many people suffer because of this.

I’ve noticed that for me, it only freezes when I’m in mobile previewer, in SM5 it works fine. Unfortunately, mine is a mobile project so I need to be in the previewer often. Anyone have any ideas? Or can confirm this is function the same way in your project? Or does it freeze in both modes?

I’ve been trying all sorts of things to figure this out. The only update is that when I test play, it freezes for 30 seconds like usual, then once gameplay begins, I immediately hit esc to exit Play mode, and the engine crashes. Here’s the error I’m getting:

Assertion failed: IsInRenderingThread() [File:d:\build++ue4\sync\engine\source\runtime\rhi\public\RHIResources.h] [Line: 100]

I really don’t want to send the project files to anyone, because this is a big project, and it has a lot of content I don’t want shared with anyone yet. Don, I appreciate your willingness to help, but I’m sure you understand. This isn’t some little project where I’m just trying to learn the engine, this is my baby, and I’m looking to build a career off of this game. High hopes, I know, but nevertheless, I wouldn’t feel right handing something so precious to me over to someone I don’t know. If you’ve got any new ideas from the most recent error, I’d love to hear them! On the other hand, if you’d like to play an earlier version of the demo, I’ll happily send you a copy!

Of course I can understand and respect that you don’t want to share it. It was just a suggestion, so no worries.
I will try to look for possible solutions and yes I would be more then happy to try out a demo! I’m learning myself too :slight_smile:

If this looks like youre issue (it’s mine) please vote for its attention here: Unreal Engine Issues and Bug Tracker (UE-74156)

Mine’s on PC, and I’m not building for Android. Still no luck on my end!