Download

Editor giving weird bug (meshes snapping out of place suddenly)

Hi everyone,

I have been building a map for a while now and recently my editor has started giving me a weird bug(?). Basically, this map has a few thousand static meshes and a few hundred BPs tops. What happens is sometimes when I add a new mesh, move a mesh, edit scale, or most kind of editor actions really, one of my pre-existing meshes on the maps disappears from its location and appears somewhere else.

I realize this is a bit hard to imagine, so I’ve included a 3MB mp4 file recording of my editor of when this happens. You can see that the two walls that appear on the left when i move my camera left/right are actually part of a group of walls on the right, and they disappear from there and appear on the left. I’ve tried looking a lot for a solution for this online but could not find anyone having the same issue. Any help would be appreciated.

I’ve tried to delete the built data of the map and rebuild, building lighting, editing in unlit mode, and several other things but nothing has helped so far. I also don’t know if this is an issue but my current project size is ~100GB because it has a bunch of assets I got from the marketplace (not nearly half of which are actually being used). My plan is to clean this up after I am done with the map and migrate it to another project completed. Not sure if this has anything to do with the issue as well.

Short video of the issue:
https://drive.google.com/file/d/1jZS…ew?usp=sharing

Thanks a lot,
Nader