Editor freezes whenever clicking on dropdown menus

I’m posting in rendering section because I think that is a problem related to my pc not able to render correctly UE user interface.

Clicking on almost any menu that should open a dropdown list makes instantly the editor not responding, hence I’m forced to kill all its processes. Why almost? Because some opens but flickering.

E.g.: right click in the viewport, everything opens a flickering dropdown list except from “attach to” which freezes the editor.
After the editor freezes, the graphics of the menu I tried to open stays static (is always visible on my display also if I open other programs).

A photo:


  • reinstalling graphic cards drivers (nothing changed)
  • reinstalling unreal engine (nothing changed)
  • using “-opengl” as target (fixed issue opening the launcher)
  • modifying “windowswindow.cpp” (nothing changed)
  • disabling “windows composition” (made editor and launcher not responding and not possible to open them)

If anyone can help me please I’d be very thankful.


OS: Win7 64-bit SP1

CPU: i7-4710MQ CPU @ 2.50GHz (8 CPUs)

RAM: 8gb

GPU: Nvidia GeForce GTX 860M

I also attach the [DxDiag][2] for further details.

If you have your video card overclocked try putting it back to stock settings, even if the card performs fine in game it is completely different when in the UE4 editor.

I had a similar problem but if you could let me see your logs from the project, saved-> logs folder.

Nothing seems to be going horribly wrong from what i can see in those logs, the only thing that stood out to me was that you are using 70% of your total Vram which could cause some instabilities as you have very little left over to load what is on screen etc.

[2016.10.17-23.32.53:612][ 0]LogRHI: Texture pool is 1361 MB (70% of 1945 MB)

So maybe try and lower it and see if that helps, if not i am not entirely sure.

No, unfortunately isn’t even that the issue, as that texture pool was way smaller, because I thought it was better for the performances, but after I saw nothing practically changed when I made it bigger, I just left it like that.

I think that the problem is my integrated gpu that get’s called to render unreal engine user interface, instead of letting do that only to my dedicated gpu, but the integrated one is not powerful, hence the glitches.

I’ve found the solution, finally!

  • Right click on desktop
  • go to Intel graphic properties
  • In the “3D settings” tab I turned off and disabled all the options
  • In the “Display settings” tab I set the scaling at “maintain display scaling”

Just that. Hope it can help also others.

I’ve read around to play a bit the performance setting of the system properties (right click on computer, properties, advanced system settings, performace, settings) but it didn’t really mattered in fixing this issue.

My integrated gpu is an Intel 4600.