Download

Editor Freeze every 5 seconds problem "workaround solution"

Some people including me have found out that at some time the editor started lagging every 5 seconds or so.

Here is a post in which PacoChan found a solution:

https://answers.unrealengine.com/questions/12933/im-suddenly-getting-some-stuttering.html

That worked at first but when I restarted my computer the problem persisted.

As I found out, typing “set android_home” on the command prompt returned me the environment variable with the android path although I had erased it from the environment variables window.

As I am a noob at windows and haven’t yet found out how to delete environment variables permanently I have created a .bat file to start the Unreal Engine 4 launcher for me clearing everytime the environement variables.


set android_home=
set java_home=
set ant_home=
cd C:\Program Files\Unreal Engine\Launcher\Engine\Binaries\Win64\
UnrealEngineLauncher.exe

To use it simply copy it in notepad and save it as a .bat file.

This should work in 64bit architecture computers, as I have the engine installed in one.

If anyone, however, could teach me how to delete enviroment vairables forever that would be awesome.

Hope this post helps.

  1. Right Click on My Computer > Properties

  2. Advanced System Settings > Advanced Tab

  3. Click on Environment Variables…

This will show you all your environment variables, I’m not sure where UE houses theirs, but it’s probably in the PATH variable.

Yes, I removed them from there, and when I restarted my computer they were gone, but typing their name on the terminal they were still set, just not appearing on the environment variables window.

I notice that enditor tries to run something on adb every 5 sec and thats why it frezzes, i susspect it might be device detection. I fixed that by templeryly (until i will need it) renamed adb.exe