Editor crashing in graph editor

The editor is becoming unresponsive very often when using any graph editor (Material and Blueprint). It happens even in new blank projects on the launcher version of 4.13.1. I am on MacOS Sierra.

Hello VoidGoat,

You say it is becoming unresponsive so it leads me to believe this is either due to the new Sierra update, or your hardware. Can you provide me with your system specs so I can take a look at your hardware and driver versions?

Also if you are getting any sort of crashes or performance issues, can you provide me with the logs or more details in regards to what you are doing when you see the performance drops.

Let me know if you have further questions.

Cheers,

Andrew Hurley

Hi,
I don’t think it is a problem with the hardware since i did not have any problems running it before 4.13. The performance is still ok it just crashes constantly. Here are my specs

110606-screen+shot+2016-10-12+at+6.44.43+pm.png

sometimes I have to force quit the engine, and sometimes it just crashes. [Here is a log][2] [Here is another log][3]

So in order to investigate this performance issue fully, I will need the crash logs more specifically and some idea of what you are doing when you are seeing the drops in performance and crashes. You mentioned in your original post that it has to do with working in the Material Editor or Blueprint graphs. Is there a certain material or blueprint logic setup I can test so this occurs on my end?

Could you take a look at our How to Report a Bug page on our new Support Page to get a better understanding of the typical information we will request when users are reporting a crash or bug.

Let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley

Im not sure what you mean by crash logs, those are logs from when it crashed? Is there something else in the Crashes folder? I have sent all reports of crashes when they occur.

Basically anything can cause it to crash. Making a new node, editing values in a node, dragging a pin out or really anything in the graph editor.

So I need your EpicID or MachineID which is produced when you get the crash to occur at the top of your logs before the callstack. If you can provide me with your full callstack including the ID’s then we can continue to investigate your crash.

Thanks,

Andrew Hurley

MachineId:9ED3231778404CD64EEFC295584468EC
EpicAccountId:d69e99ce7d8a43a9a925913f345bcf00

here is a a diagnostic

link text

Thank you for that information. So, I have not been able to get any sort of crash to occur on my end using a Mac that has almost identical specs. I have attempted to work in the Material Editor for about half an hour and still got no crash.

Unless there are some exact steps or specifics on how to get this issue to occur, there isn’t much in the way of reporting I can do. I will say, there have been a number of somewhat generic crashes on Mac in the 4.13 release which have been addressed by our engineers already. The preview release for 4.14 begins very soon, so perhaps try getting that version to crash as well.

Let me know if you have further questions.

Cheers,

Andrew Hurley

A weird thing I found that has worked everytime is creating a vector * float node in the blueprint editor and clicking right on the right edge of the float value. When I do this multiple times the editor crashes.

111437-screen+shot+2016-10-18+at+1.09.29+pm.png

Other things like just connecting nodes and clicking on pins to edit them will sometimes also cause it to crash.

I still cannot get it to crash on my end. I have tried working with some blueprint logic and following any of the repro cases you have given me, but it just is not happening.

I will continue to try and get the crash to occur, but if I am unsuccessful this might be a hardware or driver issue. That doesn’t seem likely, but the fact I cannot reproduce the crash on my end suggests that it is something on your side.

Keep trying to find a few more test cases, but if there is nothing else to report we can talk about other solutions.

Thank you,

Andrew Hurley

Just tried the 4.14.0 Preview 1 and experienced the same crashes. Mostly when clicking on pins to edit them or connecting them to other pins. Do you have any ideas of what could be causing this on my end?

Just tried with 4.12.5 and had all the same crashes again, which didn’t happen before with 4.12. This makes it seem like it is something on my end, or just a problem with macOS Sierra.

Yeah, that would explain why I cannot get the same crashes to occur on my end. Although tempting, typically when a new operating system is released, you want to wait a little while before upgrading for other companies and programs to integrate full support. This allows us to fully test and fix any issues that appear on our end. With that said, we do have devs on the macOS Sierra and have not experienced the crash you are reporting.

If you discover any new information or reasons as to why this issue is occurring, then you can return here with a comment. For now, since we cannot reproduce the issue I am going to close this post. Leaving a comment will reopen the issue.

Thank you,

Andrew Hurley