Editor crashes when using DX12 and/or Ray Tracing?

I’ve been looking to try out the ray tracing stuff in 4.22 but when I start the editor in DX12 mode it crashes either on launch or when I open an asset like a material or object.

When I run the same project outside of DX12 mode it seems to open and run fine.

There are a lot of messages in the output log saying :

LodD3D12RHI: Display: Root signature created where the root parameter akes up 16 DWORDS. Using more then 12 WORDs can negatively impact performance depending on hardware and root parameter usage.

I don’t see those messages when I open the project outside of DX12 mode

Anyone got any ideas? I’ve got the latest drivers and windows 10 version 1809 so as far as I can tell everything should be working

Some further info, having experimented a little I can see that I get the same DWORDS errors when the engine uses DX12 without ray tracing, but it doesn’t crash when opening a tab or windows that contains a viewport/3D preview.

Also I can see that ray tracing is in fact working properly before the editor crashes. If I don’t open a tab that contains a 3d preview window or viewport I can look around the scene, change materials and so on.

It will further improve analysis, sending the crash bug reports when the dialog appears and if it does not appear to automatically send it, fill a bug submission form and send the log files attached to it and maybe also in this thread. You didn’t mention your graphics card model and driver version btw, that would also help, thou they appear in the log.

Hi Nilson,

I never actually get an error dialog, the engine freezes and seems to never unfreeze. In the task manager it is listed as not responding. I’ve only waited for about 15 minutes when it gets into this state.

I’m using a laptop so it has both an RTX 2080 and an Intel integrated graphics system. Disabling the Intel card doesn’t seem to change the issue, and as I said I can see in the initial viewport that the ray tracing is working. The LogInit line shows

LogInit: OS: Windows 10 (Release 1809) (), CPU: Intel(R) Core™ i7-8750H CPU @ 2.20GHz, GPU: Intel(R) UHD Graphics 630

or if I disable the intel GPU in the device manager

LogInit: OS: Windows 10 (Release 1809) (), CPU: Intel(R) Core™ i7-8750H CPU @ 2.20GHz, GPU: NVIDIA GeForce RTX 2080 with Max-Q Design

The whole log on start up is attached. That is the Output Log from the editor, if there is a different log you want me to find let me know. As I said I don’t get a crash report as the editor just freezes

Thanks in advance for your help!

The only weird stuff I see on the logs is more a warning per say, like these two lines which appear quite frequently:
LogD3D12RHI: Display: Root signature created where the root parameters take up 15 DWORDS. Using more than 12 DWORDs can negatively impact performance depending on the hardware and root parameter usage.

LogD3D12RHI: Display: Root signature created where the root parameters take up 18 DWORDS. Using more than 12 DWORDs can negatively impact performance depending on the hardware and root parameter usage.

I have no idea what they mean, but might be related.

Also, maybe the best way to disable the Intel Integrated Graphics card is by BIOS setup.

I have seen an increased amount of bug reports from laptop users, lets just hope Epic can take a look on whats going on.

So its seems like this is some kind of clash between the Intel GPU and the Nvidia card. Tahacannn on the Unreal Questions page found a work around.

Basically start the editor with the -dx12 argument and get the project to the point where ray tracing is working, or just open the project if you are already at that stage.
Minimise the window (this is important) then open the device manager and disable the Intel display adaptor. Then you seem to be able to use the editor as expected.

For whatever reason, this doesn’t work if you disable the Intel GPU before opening the editor…

I don’t think that is the case that it is a clash between GPU’s. I am using an r5-1600 and r7 1700 with a gtx 1060 and an r9 590 respectively and I am receiving this as well.

I’m having issues with this, and I’m finding it that because I’m able to somehow load a dummy map with nothing on it, that the problem lies in specific materials. Some specific materials crash when compiling in the D3D12 RHI and raytracing on. I’ve not narrowed down why this might be (as I don’t know how materials work at their very core), but I think the problem is some of the materials are too complex for raytracing to handle.

Hi all,

Stability is our main priority for 4.22 hotfixes and for 4.23. The ray tracing technology is built on top of other components that are also brand new, or less tested than the classic UE4 path:

  • It is build on top of the DX12 layer, which was not the default mode in UE4. Many of the issues found when using ray tracing actually were DX12 issues. We have fixed many of them in 4.22.1 and 4.22.2, and we have just fixed another one that will be released in 4.22.3 (no fixed ETA there but very soon)

  • It is also built on top of the major refactoring we did in the rendering pipeline. It is quite stable now, but it took time to get there.

  • It is also built on top of DXR, a brand new tech developed by a 3rd party (Microsoft) and using a drivers layer developed by another 3rd party (Nvidia)

  • And of course, on top of these potential sources of instabilities we could have ray tracing specific issues.

That is why ray tracing was tagged as Early Access, and that is why our focus in the next months is stability and performance (although we are also working on new features and things that were not supported in ray tracing in 4.22 such as landscape, which I hope you like!). We are quite happy with how things are going so far and we are doing our best to make it even better in 4.22.3 and 4.23.

We have just found a problem with complex materials that have tessellation enabled. We have a potential fix that we are evaluating right now, hopefully it will be included in 4.23. You can try disabling tessellation for the material and seeing if that avoids the crash. It is actually not a ray tracing bug, even not a DX12 bug but it manifests as a crash in DX12 mode, while in DX11 it just fails silently (despite the shader network might generate an invalid output).


+1 Issue.
Running on Windows 10 1903, Latest Nvidia driver.

Crashes saying Video driver crashed. Please update to latest driver


I think I am getting the same or a similar issue on 4.22 or newer where the display driver hangs at startup. Actually for me this seems to be a general DXR issue (more on that below). I am running a RTX 2080ti.

I tried the usual: updating all the drivers and Windows, downgrading the GPU drivers, then went further and tried extending the TDR time, flashed the bios made a sacrifice to the elder gods etc.

It didn’t happen for me before (a month or two back), but it is hard to pinpoint what exactly changed during this time frame.

For me EVERY application that uses DXR (except for Quake II RTX demo curiously) in addition to UE Battlefield V, 3Dmark port royale, the Reflections demo a compiled hello world DXR sample provided by microsoft and so on crash at startup.

I am not sure where to continue debugging this, I wrote to Nvidia support, but still waiting for a reply (that is hopefully different from reinstall all the drivers for a n-th time)

Event viewer offered these errors:
Graphics SM Warp Exception on (GPC 3, TPC 0, SM 0): Illegal Instruction Encoding

Graphics Exception: ESR 0x51c730=0x9 0x51c734=0x0 0x51c728=0x7c12b72 0x51c72c=0x174

But my Google Fu didn’t get me anywhere with this.

Please make sure you all are filling out bug reports too! All that information helps our teams track down these issues.

Has this been resolved?

its jan 2021 and my editor crashes upon starting up my project, cant get in to change back to default RHI, what is going on?

Open your windows explorer, under the documents folder, search for “Unreal projects”> (Project name)> Config folder and open ‘DefaultEngine.ini’ using notepad, scroll all the way down and replace the line ‘DefaultGraphicsRHI=DefaultGraphicsRHI_DX12’ with ‘DefaultGraphicsRHI=DefaultGraphicsRHI_DX11’.

Hope this works for ya !

Won’t this then disable RTRT ?

I just found a solution. If you have the nvidia dlss plugin enabled, then just try to disable it. It helped for me.