Editor crashes when using custom GameInstance (4.7 preview 8)

Hi all,

Lately I’ve been having trouble with the following issue:

UE-3480 Launching a project with a
custom Game Instance assigned will
receive an error and crash the
launching window

I’ve come to learn that this issue was apparently fixed back in preview 5, however I’ve been experiencing it consistently throughout 4.7. When I launch my project without the GameInstance file in the Content folder, the project launches fine (aside from the “Can’t find file for asset” messages).

It’s pretty puzzling. Does anyone else have any experience with this issue, or any insight?

Hi zerofiftyone,

The JIRA you mentioned was for a crash that occurred if you created a new GameInstance & add it to the project > then pressed Launch. I just attempted to reproduce this in 4.7. Preview 8 but so far I haven’t been able to. What steps are you using?

Ah, so it appears to be a separate issue. The problem I have occurs when converting an existing 4.6.1 project up to 4.7. When that project has a custom GameInstance file assigned, the editor crashes on launch (by which I mean on opening the project, not running the game).

Sorry for any confusion; I assumed from the bug description that this was the same issue!

Edit: Here’s the crash report: http://pastebin.com/Mf85PKHw

I tried creating a new 4.6.1 project > create & add a new Game Instance > then convert it to 4.7 Preview 8. So far it is working correctly for me. Do you have a small test project that you can upload that has the issue?

Well this is interesting. I just tried with a new project and it seemed to work. Even when I imported the GameInstance file from the original project it still worked.

Weird. I’ll do some more digging to figure out what’s going on with my project that’s causing this.


I got it working. The problem seemed to be with that particular GameInstance file. For reasons I can’t understand, the project works fine now that I’ve rebuilt that file from scratch and used that instead.

Thanks for your help TJ. :slight_smile:

Fixed it. I ended up having to scrap the GameInstance file, upgrade the project to 4.7 and then rebuild the GameInstance file from scratch.

I don’t understand why it works, but it does! That’s game development, folks!



But there’s a twist! Turns out that my project is still broken :(. Once I closed it and reopened it, the problem arose again. :frowning:

It turns out the ACTUAL problem was down to a bad macro library, a similar case to this thread:

Once I got rid of the macro library and replaced the references, the project seemed to launch okay. /fingerscrossed