Editor crashes when painting on certain landscape tiles

My world is built out of tiles using the world browser.
For no reason I can find, when ever I paint certain tiles, my editor will crash. Can someone tell me why or how to fix this? This literally makes me unable to work on my project anymore.


Could you assign a crash log? It hard to say what might me wrong without it.

Could you paint some foliage on a landscape tiles that cause crash, and the check if sculpting still cause crash on them?

Ok, so this is my log: http://hastebin.com/tehalenuku.tex and here is the dmp:
http://wikisend.com/download/826594/Dump276410336.dmp - my engine version is 4.2.0 self compiled.
The log says this is the line that crashes: LayerNoWeightBlends[LayerIdx] = Allocation.LayerInfo->bNoWeightBlend;

Adding foliage and sculpting seems to work, but painting will make it crash/close.

Some things I tried:

  • Recreating the paint LayerInfoObjects doesn’t work
  • Applying a different material to paint doesn’t work.
  • Sculpting the landscape before trying to paint doesn’t work.
  • Adding foliage to the landscape before trying to paint doesn’t work.

Btw, is there any ETA on when 4.3 is coming out? Also, if you have any code snipplets that would fix the issue, I can implement them. But some trick to re-validate/fix the tiles would do as well.

Oh well, I recreated the tiles. Hope I can keep it from corrupting again.

It would helpful if you can recreate this issue in a isolated project and send that project to me. So I can fix the crash. I have tried to reproduce it without any success. It seems like one of the LayerInfo objects is null. Probably this could happen when you create new LayerInfoObject asset, assign it to a landscape layer, save the map without saving the created asset. So next time you open this map references to a LayerInfoObject will be lost.