Download

Editor Crashes When Launching to LG V10 Android 6 Phone

I’m following the Android Quick Start and have created a 3rd Person Blueprint project and I’m trying to see it run on the phone via launch. Note, the phone is connected and is displayed via adb and in the Launch menu. When I click Launch and select the device, there is a long pause as it builds (30 seconds or so). Afterwards, it displays a popup indicating that it is launching to the device. Immediately afterwards, the editor crashes. Not a graceful crash that asks if I want to send the logs. It’s the “you’re screwed” crash from Windows that says the app has crashed. I do not see any crash logs, so I’m not sure what else I can provide to help diagnose this.

Any help would be greatly appreciated.

EDIT: I tried creating a package and then deploying it to the device and it works fine. After doing so, I tried the launch again and it failed the same way. This time I told it to debug the editor and I got this popup in Visual Studio:

83d299db31caa4e5f301f54a9bf4dd4f1fe4af29.jpeg

This is a crash during cooking. In this case it looks like a problem with the texture compression library. Please create an AnswerHub post along with your system information.