Download

Editor crashes when importing skeletal mesh.

This problem as been asked some times in the past but i don’t find a solution for it.
Simply when i try to import a mesh from 3ds max and i check skeletal mesh the editor crashes.
I’m trying with a simple cone, i exported in fbx using both ascii or binary to try but it doesn’t resolve the problem. I’m testing this cone as a skeletal mesh to make local volumetric fog.
I think this problem is common. I’m using 24.1 engine version.

I just tried importing it in 4.22 and this time it didn’t crashed…this is strange.
Now the 4.24.1 version is downloading a new version…let’s see if it will work after this.

Make sure the asset is complete.
at the very least, add a material.

Why a skeletal mesh for volumetric fog anyway?
does it actually have an armature or morph target assigned? That may be the issue too.

Your 3DS Max is probably exporting a FBX version not supported by the engine.
Epic doesn’t always support latest version of FBX sdk.

I imported a lot of assets from 3ds max in fbx, all that assetts where only mesh, the problem is given only if i check skeletal mesh. I need it because i created a particle system to make a cloud and then i need a skeleton mesh to use in the particle system.

I use Maya and I export things using the 2016 version just to be sure I won’t have this kind of problem.

Ok…after the engine upgrade to 24.2 now the skeleton import works…this is very strange. I used the same fbx version used in 24.1 and in 22…but it only works with 22 and the last version.
I read a lot of other developer having the same problem like me, someone solved it importing into another previous working versione of UE and then migrating to the not working one. So it should be a UE4 recourring bug!

some times the devs loose or revert some commits. it happens.