Editor crashes when I close preview

I am currently running 4.5.1. Everytime I preview my game, when I close game, it crashes editor with following error:

Access violation - code c0000005 (first/second chance not available)

UE4Editor_Engine + 6469423 bytes
UE4Editor_Engine + 15037943 bytes
UE4Editor_Engine + 6284681 bytes
UE4Editor_Engine + 1652687 bytes
UE4Editor_Engine + 1919511 bytes
UE4Editor_Engine + 1919062 bytes
UE4Editor_Engine + 4860148 bytes
UE4Editor_Engine + 9735809 bytes
UE4Editor_Engine + 9734998 bytes
UE4Editor_UnrealEd + 4531348 bytes
UE4Editor_UnrealEd + 4170183 bytes
UE4Editor_UnrealEd + 1890676 bytes
UE4Editor_UnrealEd + 6486374 bytes
UE4Editor!FEngineLoop::Tick() + 3524 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\launchengineloop.cpp:2129]
UE4Editor!GuardedMain() + 479 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\launch.cpp:133]
UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\windows\launchwindows.cpp:201]
UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

It has been doing this for a long time now, but is now every single time I close preview. A similar type question also requested dxdiag, so I’ve attached it.
link text

Hi Interitus,

Does this crash occur in a new project, or only in your current project? Can you also and attach your crash log and dump file for project after this crash occurs? You can read about where to find that information here:


This crash has been in my current project, havent tried anything else yet. Will start a new project and see what happens.

Update: It appears to only happen in my current project.

link text
link text

Hello Interitus384,

Can you try to reproduce this crash in 4.6 preview? Please make a copy of your project and try that. We’ve implemented a fix for a very similar crash, and it may have fixed your crash too.

Sorry, I was unable to work on project for a few days, but have been unsure how to access 4.6 preview. I dont use code, so I cant compile anything.

If I remember correctly, problem went away next day, but has been fairly intermittent. Within game, I spawn an actor in game, and after doing so there is almost always a crash. I’ve taken a break from this project due to a creative brick wall, and lack of time to work on project. But I will revisit once 4.6 is released through launcher.

If you’re using Launcher version of editor, you can click “+” at top of launcher to add an engine slot and then select ‘4.6’ from dropdown. We’ve officially released 4.6 now, so you won’t need to use preview regardless.

Let me know if you’re still seeing crash in 4.6.

I converted my project to 4.6, and once I resolved some UMG errors with bindings to pure functions, I ran program twice, and it crashed both times.

Access violation - code c0000005 (first/second chance not available)

UE4Editor_Engine + 6528719 bytes
UE4Editor_Engine + 14212108 bytes
UE4Editor_Engine + 6338601 bytes
UE4Editor_Engine + 1448061 bytes
UE4Editor_Engine + 1746262 bytes
UE4Editor_Engine + 1745798 bytes
UE4Editor_Engine + 4843092 bytes
UE4Editor_Engine + 9792769 bytes
UE4Editor_Engine + 9791972 bytes
UE4Editor_UnrealEd + 4665715 bytes
UE4Editor_UnrealEd + 4297607 bytes
UE4Editor_UnrealEd + 1799156 bytes
UE4Editor_UnrealEd + 6686342 bytes
UE4Editor!FEngineLoop::Tick() + 3876 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launchengineloop.cpp:2214]
UE4Editor!GuardedMain() + 479 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launch.cpp:131]
UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

Is there anything I can do on my end to try and track down whats causing this? Being a novice programmer I dont have slightest clue where to start looking.

Please try going into Editor Preferences->Blueprint Editor->Save on Compile and set it to ‘Never’. User xdbxdbx found this workaround in another thread.

We’ve isolated an issue with Save on Compile. We’ve got a fix and we’ll deploy it when possible.

Hmm… I loaded up editor and it was already set to “never”.

Okay, that means that your issue is a different one.
You said that it crashed when you ran it. Do you mean when you opened editor, when you hit Play in Editor, or when you launched a Standalone Game?

Sorry if I was unclear, I play in editor, either viewport or a seperate window, when I close game, it hangs for a second and closes both preview and editor.

Are you still running into this issue, Interitus?

I’ve discontinued work on that project, and havent done any work on it since early december, but I just loaded it up again to test, and problem is still there. If I ever make it back to this project, I will probably start from scratch. It was my first project and if you’ve been unable to reproduce on your end, could be just bad programming by me.