Editor crashes when compiling Blueprint after adding/removing any node


I have a really weird issue, the editor crashes every time when I add or remove any node in a specific Player Controller Blueprint after I hit compile. In the log file the very last entry is that the Blueprint was compiled successfully. If I reopen the project, the changes I made to that Blueprint don’t get lost, everything is there and working as it should when you compile, except there is a crash before it 10/10 times. The issue is certanly not related to any referenced variable, as simply adding a Print String node then hitting compile causes crash. When I reopen the project, the Blueprint is marked as compiled (and again, for example the Print String node don’t get lost) and if I hit compile again (not sure tho if it is doing anything when the Blueprint is already compiled) the crash does not occur.

Adding and removing variables then compiling does not crashes the editor, so I am really puzzled as it doesn’t seem to be related anything else then adding/removing nodes (any nodes). The issue is only occuring in that specific Blueprint. I uploaded the Crash Log files to Dropbox, here is the link: Dropbox Link.

I tried, but was unable to reproduce this in a clean project, the issue only appeared today after working for a few hours in that Blueprint and experienced a crash.



Could you please cause the crash to occur again, and provide the Machine ID and ensure that you send the Crash Report?

Hi Sean,

I reopened the project and now the issue is gone. It makes the problem even more weird, because I haven’t done anything else since my original post then giving up and closing the editor. Obviously I tried to restart the editor and my PC several times but it didn’t help then.

I also found out that the crash only occured if I made changes in two specific event graphs in that Blueprint, nowhere else.

I cannot provide a fresh log, as the issue is gone, but I sent the crash report every time with my Machine ID, allowing Epic to contact me, so I hope those will help you guys find out what just happened (there are plenty, I tried to pinpoint the issue).

Thanks for the support!

Could you elaborate a bit more on the changes that you’ve made in your event graph that caused the crash?

If you do get the crash to occur again, please do provide your machine id, as this will allow me to look up the crash report.

Hi Sean,

Simply adding a Print String node anywhere in those two event graphs caused a crash after a hit Compile. I could save the Blueprint and the project without any problems (probably the reason why the changes were still there after the crash). Again, when I reopened the project, Print String was there, Blueprint was compiled successfully, and the node would function as expected.

I tried it with several different nodes, same result, delete any existing node in those graphs then compile: crash

Adding and removing variables to the Blueprint then recompiling still worked without any issues.

I am pretty sure that I have included my Machine ID in the crash reports. Are you unable to find them, or you just saying to keep this habit in the future?


Have you been able to reproduce this crash in a clean project?

Also, the Machine ID is included when you send a crash report, but in order to look up the report, we will need to have your Machine ID, which I don’t see anywhere in this post (please correct me if I’m just overlooking it).

Oops, I don’t know why I thought you can associate it with my AnswerHub account. I sent you a private message on the forums providing my MachineID.

Answering your question, no I haven’t been able to reproduce this in a clean project, but it occured several times since then in different Blueprints, but fortunately the crashes only occured once, so after relaunching the editor I could keep on working on that Blueprint without any further problems. In each scenario, the last entry in the log file was that the Blueprint was successfully compiled, so the crash wasn’t caused because of some compile error (according to the log at least).

I hope this information helps.

I’m seeing multiple crashes appear under that ID. Could you cause the crash to occur again and copy the first few lines of the callstack so I can identify which crash we are focusing on?

Hi Sean!
Yes thats possible, I usually send my crash reports. Because of the nature of the issue I cannot directly reproduce it, however, if that helps, I can update this thread with the required information if I experience it again. What exactly do you mean by the callstack? (sorry I am an artist :P)

The callstack would be the function calls listed in the crash reporter window when it pops up. As an example:

UE4Editor_Engine!USceneComponent::OnComponentDestroyed() scenecomponent.cpp:680
UE4Editor_Engine!AActor::MarkComponentsAsPendingKill() actor.cpp:3723
UE4Editor_Engine!UWorld::DestroyActor() levelactor.cpp:640


I am marking this topic as resolved for tracking purposes, as we have not heard from you in a few days. If this issue persists, feel free to respond to this thread. For any new issues, please create a new Answerhub topic.

Have a great day