Editor crashes upon stopping PIE game

I just recently added swiping and pinch-pull support and I’ve been testing my game constantly over the past few days on both Windows and iOS. Today I just created a very simple widget, and now the editor will crash consistently whenever I exit a Play-In-Editor game through Esc or the Stop button. Nothing should have changed since last night except for creating the widget (that isn’t even referenced in the game yet), and I’ve deleted the widget with no change in luck. I’ve restarted the computer and Verified the engine (not sure what that does).

I’m using 4.6.1, primarily the binary version. The Source version experiences the same issue.

The crash log says that it is:

[2015.01.20-21.53.19:358][391]LogWindows: === Critical error: ===
Assertion failed: IsValid() [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.6\Engine\Source\Runtime\Core\Public\Templates\SharedPointer.h] [Line: 658]

Log and Dump


Hello StephaBon,

Thank you for the information provided. However, I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this in a clean project?
  2. If so, could you provided a detailed set of steps to reproduce this issue on our end?
  3. Could you provide of a screen shot of any blueprints that may be involved?
  4. Are you receiving any errors (other than the crash)?
  1. I have tested out multiple other projects in 4.6 and I do not have this issue.

  2. The widget I created that morning was just an image with an animation that would loop every second. It was never actually implemented when I got my first crash, and I think it was just coincidence.

The level blueprint contains the issue I will describe below, but it hasn’t been changed in a long long time, and this error sounds like an engine code thing (BuildFarm?). My project uses no C++.

  1. That got me thinking. Recently I was getting a weird error that an Array couldn’t get called, but the node that it pointed to didn’t call any arrays and the gameplay that used arrays worked flawlessly. I happen to have an older version of this project that has this same error, and I just fixed that error by deleting two unused pins in a Make Array node in my Level Blueprint (which seems like it shouldn’t be a critical error).

I was hoping that this would solve my problem in my current project, so I followed the same steps and fixed the array issue. After playing the game once and stopping it, the editor finally managed to survive, but my next three attempts to hit “Play” and “Stop” resulted in an immediate crash.

The stupid thing about that array is that it did not used to have errors until one random day when it hadn’t changed. On top of that, the errors would only pop up after calling a certain function, and these crashes are unrelated to any gameplay actions.

TL;DR Yes, I did have errors. Now I’ve fixed them, but the crashes don’t care. The game works just fine and new blueprints work as expected. It’s only when the game closes and the editor tries to clean up that I get a crash. I have to test in a standalone game right now.

Hello StephaBon,

Would it be possible for you to send me a simplified version of your project. That produces the crash? I would only need enough of it to still cause the crash. I also have another suggestion. Does it make a difference if you delete the saved file and then relaunch it?

Deleting the Saved Folder and Build folder does not fix it.

I managed to get it down to 130 MB. You should be able to get a crash by just playing the game and closing it, regardless of how much time it is active.

Google Drive made it a file directory even though I uploaded a .zip.

Another thing, I had a second level that I used as a small testing ground, and I do not get crashes when playing that level. So it is not a project problem, but a level? One step further, I guess.

Hello StephaBon,

Could you try the following method in order to send the project it’s the easiest way I have found to share test projects is like this:

After zipping it down, just use the attach button in the reply :slight_smile:
(Note the zip file must be under 10 MB)

Woops! Turns out I just linked to the wrong file. Sorry about that : ( I promise I know how to zip a folder.

Unless I’m misunderstanding you, you want me to get my entire project below 10 MB?? I just deleted every single texture and it’s at 90 MB still, so here is a dropbox link

Thanks for your help.

Hello StephaBon,

I after downloading your project and taking a look at it I wrote up a report ( UE-8065) and sent it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your information and time.

Make it a great day

what was the issue? this doesn’t answer the question, what was done to fix this I have the same problem in 4.25