Editor crashes on startup

Hi,

I’m trying to use Unreal Engine 4 on Mac OS X 10.10.4, but it appears to crash on startup after initializing everything (crashes at “Loading: 83%”).

Here is the crash report:

MachineId:5408F044AC45253743CDE18F57B39653
EpicAccountId:--removed--

Generating report for minidump

Application version 4.8.3-0
 ... built from changelist 2634408

OS version 10.10.4.20038
Running 1 x64 processors
Exception was " SEGV_NOOP at 0x0"

Source context from ""

<SOURCE START>
<SOURCE END>

<CALLSTACK START>
objc_release Address = 0x7fff8e1b944f (filename not found) [in libobjc.A.dylib]
(anonymous namespace)::AutoreleasePoolPage::pop(void*) Address = 0x7fff8e1b7e8f (filename not found) [in libobjc.A.dylib]
_CFAutoreleasePoolPop Address = 0x7fff996236f2 (filename not found) [in CoreFoundation]
Unknown() Address = 0x7fff960c8013 (filename not found) [in Foundation]
FMacPlatformProcess::CreateProc(wchar_t const*, wchar_t const*, bool, bool, bool, unsigned int*, int, wchar_t const*, void*) Address = 0x1098badef (filename not found) [in UE4Editor-Core.dylib]
FDesktopPlatformMac::OpenLauncher(bool, FString) Address = 0x112ae5dee (filename not found) [in UE4Editor-DesktopPlatform.dylib]
UEditorEngine::InitEditor(IEngineLoop*) Address = 0x1108aaa92 (filename not found) [in UE4Editor-UnrealEd.dylib]
UEditorEngine::Init(IEngineLoop*) Address = 0x1108afb14 (filename not found) [in UE4Editor-UnrealEd.dylib]
UUnrealEdEngine::Init(IEngineLoop*) Address = 0x110f659ca (filename not found) [in UE4Editor-UnrealEd.dylib]
FEngineLoop::Init() Address = 0x1096771ff (filename not found) [in UE4Editor]
EditorInit(IEngineLoop&) Address = 0x110f626b7 (filename not found) [in UE4Editor-UnrealEd.dylib]
GuardedMain(wchar_t const*) Address = 0x10968293c (filename not found) [in UE4Editor]
-[UE4AppDelegate runGameThread:] Address = 0x109692583 (filename not found) [in UE4Editor]
-[FCocoaGameThread main] Address = 0x1098154ae (filename not found) [in UE4Editor-Core.dylib]
Unknown() Address = 0x7fff960eadc2 (filename not found) [in Foundation]
_pthread_body Address = 0x7fff9689c268 (filename not found) [in libsystem_pthread.dylib]
_pthread_body Address = 0x7fff9689c1e5 (filename not found) [in libsystem_pthread.dylib]
thread_start Address = 0x7fff9689a41d (filename not found) [in libsystem_pthread.dylib]
<CALLSTACK END>

(Removed the loaded modules, but can edit it back in if need be)


Report end!

Hi russjr08,

Thanks for the report! Does this crash occur when starting the engine, or opening a project?

Would it be possible to get the Machine ID from this report so we can look it up in our system? We won’t need your Epic Account ID. Thanks!

Hi Ben,

The crash occurs right after this stage Pasteboard - Uploaded Image (I’m pretty new to UE, so I’m not sure whether this is the ‘engine’ or the editor here, it’s what opens after you click launch from the Epic Games Launcher).

Also the Machine ID is 5408F044AC45253743CDE18F57B39653

Thanks for your time!

Hi russjr08,

Another user was experiencing a crash with the same error at almost same stage of opening and this fixed their issue:

Try renaming the Launcher app to something else so that the editor cannot detect it and running the UE4Editor.app directly from /Shared/UnrealEngine/4.8/Engine/Binaries/Mac/

Let me know if it works.

Thanks

Hmm, it appears I do not have a /Shared folder. Is there any other place where the engine could be stored?

Edit: Found it, it’s under /Users/Shared/UnrealEngine/4.8/Engine/Binaries/Mac, I renamed the Launcher, and tried running UE4Editor.app, but it crashed and this time brought up the native OS X crash reporter.

UE4 Crash Log (Native OS X Crash Reporter) - Pastebin.com is the crash.

Hi russjr08,

I’ve used the information you have provided to enter the following bug report: JIRA [UE-19534]. When this issue is corrected, we will update this post to let you know. In the meantime, try uninstalling the Engine completely and then reinstalling as this has been the fix for a number of users experiencing a similar issue.

Thanks.