Editor crashes on startup / when loading a (specific) blueprint asset

Hi! Recently my UE4 froze and I had to force a restart on my computer, and it seems to have messed up my project. Whenever I try loading it up on the editor it crashes. So what I did was I emptied the “default map” line in the “defaultengine.ini” file and it sort of works, but it crashes whenever I try loading any of the assets I had open during the time of the crash (or so I believe)…

Any idea how to fix this?


One of my maps opened, but as soon as I tried it out, it crashed. :cry:

Is there any folder that I could delete or something like that to try to fix this?

Removed UE4 4.7.3, and then downloaded it again.

Still happens…

Here you guys go: Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.7\Engine\Sou - Pastebin.com

I believe the error is linked to my 2D side-scroller character, most assets open up fine, including maps that don’t have references to the character… Whenever I try opening it, however, it crashes. Any way I can fix this? I have 2 weeks of work on that blueprint alone ;-;

yep, crashes with any asset with any reference to the 2D side-scroller character…

Fiiiiiiiixeeeeeeeeed iiiiiiiiiiiiitttttttttt!!! :smiley:

Alright, so what I did was I went into the saved folder → backups, and I got an old(er) version of the blueprint that was causing my game to crash. Then I put it back into the game, and bam! No more crash.

Just wanted to say that this worked for me as well. Was having an issue where the project loads fine at work, tested on two different machines. But crashes on load on my PC at home. Performance is not the issue as they are all dual xeon gtx 1080 and 1080 ti machines. both work and home.

So in the end i copied the saved folder from a previous working version of the project. (working as in loads fine on my home PC). And it all loads without a problem now.

I tried just deleting the saved and intermediate folders but that still didnt work. I thought the saved folder is there only for backups etc. how come not just deleting it worked?