Editor crashes on project load after creating Blueprint Macro

Been working on a small project for a while. Having recently been using 4.1 to edit project but never upgraded the project to 4.1, it is still 4.0.2. Last thing I did was create a engine macro in “Unreal\4.1\Engine\Content\EditorBlueprintResources” and saved it. Now when I load my project it crashes and says;

We apologize for the inconvenience.
Please send this crash report to help
improve our software.


When I try and load my project in 4.0.2, it states my map is using newer engine version and half the assets are missing (probably the ones I edited in 4.1).

I tried removing the macro uasset but it still crashes with same error. Anyway to over come this to get access to my full project again?

This is from launcher not from source build.

Also the macro may be unrelated as all other projects open fine.

I opened the project in 4.0.2 and created a new level, set it as default and saved project. Am now able to load the project in 4.1 but when I try and load the old level it crashes editor still. At least I have access to my assets now.

Okay so I figured out it was due to the custom gamemode blueprint. Was able to open the level after removing it from project before hand. Problem is when I use blueprint drop down to create a new gamemode blueprint it crashes with same “5d619a62459d082be7bd72f65efd05b3” token.

I did a verify and it said it moved modified files, after which the project works fine. Appears to be ActorMacros and DefaultTextMaterialOpaque, two files i did not edit.

Project and level loads fine now.

How did you verify files?

In the launcher, under the drop down for engine version.

I see thanks.

I was getting that same 5d619a62459d082be7bd72f65efd05b3 crash message. Also if you have blueprint crashing when you open blueprint, I’d click on No instead of Yes to restore or try and preserve it, when I clicked Yes it would keep crashing after editor was re-opened and it would automatically load the blueprint that was crashing the editor, which at the time were in the content samples after 4.1.0 update was installed. And when you download the examples and install 4.1.0, check the Marketplace and verify if you’ve downloaded any updated samples or not for the current version you’re using, I don’t know if that’s related but I am wondering, especially if you see a popup requesting you to Apply a fix to convert it to use for current version, like it did for me, which makes me think it’s attempting to load portions of the examples from previous version paths. You see one like the Elemental Demo and it says it’s for both 4.1.0 and the version 4.0.2.

Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes.

If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, please submit a new report for it.

Thank you!