Editor Crashes On Launch On OSX 10.13

Every time I try to launch 4.14.3 (it’s the latest I can use since my graphics card doesn’t support the Metal) the splash screen doesn’t even have time to show up before I get this crash:


SEGV_NOOP at 0x0

SLSNewWindowWithOpaqueShape Address = 0x7fff5e3d9c49 (filename not found) [in SkyLight]
-[_NSCGSWindow initWithConnectionID:] Address = 0x7fff3aeaa13e (filename not found) [in AppKit]
+[NSCGSWindow(NSCGSWindowCreation) windowWithConnectionID:] Address = 0x7fff3aea908c (filename not found) [in AppKit]
_NSCreateWindowWithOpaqueShape2 Address = 0x7fff3a5a9bc3 (filename not found) [in AppKit]
-[NSWindow _commonAwake] Address = 0x7fff3a5a88b3 (filename not found) [in AppKit]
-[NSWindow _commonInitFrame:styleMask:backing:defer:] Address = 0x7fff3a3e9ea0 (filename not found) [in AppKit]
-[NSWindow _initContent:styleMask:backing:defer:contentView:] Address = 0x7fff3a3e86d7 (filename not found) [in AppKit]
-[NSWindow initWithContentRect:styleMask:backing:defer:] Address = 0x7fff3a3e818e (filename not found) [in AppKit]
invocation function for block in FMacPlatformSplash::Show() Address = 0x101943337 (filename not found) [in UE4Editor-Core.dylib]
invocation function for block in PerformBlockOnThread(FCocoaRunLoopSource&, void () block_pointer, NSArray*, NSString*, bool) Address = 0x1018f17a0 (filename not found) [in UE4Editor-Core.dylib]
FCocoaRunLoopSource::Process(__CFString const*) Address = 0x1018c729c (filename not found) [in UE4Editor-Core.dylib]
-[FCocoaRunLoopSourceInfo perform] Address = 0x1018c6ca6 (filename not found) [in UE4Editor-Core.dylib]
CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION Address = 0x7fff3cde4941 (filename not found) [in CoreFoundation]
__CFRunLoopDoSource0 Address = 0x7fff3ce9c33c (filename not found) [in CoreFoundation]
__CFRunLoopDoSources0 Address = 0x7fff3cdc7930 (filename not found) [in CoreFoundation]
__CFRunLoopRun Address = 0x7fff3cdc6dad (filename not found) [in CoreFoundation]
CFRunLoopRunSpecific Address = 0x7fff3cdc6607 (filename not found) [in CoreFoundation]
RunCurrentEventLoopInMode Address = 0x7fff3c0db866 (filename not found) [in HIToolbox]
ReceiveNextEventCommon Address = 0x7fff3c0db5d6 (filename not found) [in HIToolbox]
_BlockUntilNextEventMatchingListInModeWithFilter Address = 0x7fff3c0db354 (filename not found) [in HIToolbox]
_DPSNextEvent Address = 0x7fff3a3d89f7 (filename not found) [in AppKit]
-[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] Address = 0x7fff3ab6dd98 (filename not found) [in AppKit]
-[NSApplication run] Address = 0x7fff3a3cd805 (filename not found) [in AppKit]
tchar_main(int, wchar_t**) Address = 0x1016a9d2a (filename not found) [in UE4Editor]
main Address = 0x1016a958e (filename not found) [in UE4Editor]
start Address = 0x7fff643cc145 (filename not found) [in libdyld.dylib]

This happens on every version of UE4 except on 4.0-4.5. From 4.6 onward this crash happens.

One thing I would like to note is that this never happened before I upgraded to Mac OS X High Sierra. I have completely deleted everything that has to do with UE4 on my Mac and done a clean install of the launcher and the editor but to no avail.

I realize this is an older version, but it’s the latest version I can use. Plus, all of my projects are on 4.14.

Here are my system specs:
Mac OSX High Sierra 10.13 (17A405)
MacBook Pro (15-inch, Late 2011) 2.5 GHz Intel Core i7
AMD Radeon HD 6770M 1 GB/Intel HD Graphics 3000 512 MB

Exactly the same thing happens to me, please what do we have to do? Also I’m unable to use more recent versions since my video card does not support metal.

System specs: Mac OSX High Sierra 10.13, Mac Pro (Mid 2012), 2 x 2,4 GHz 6-Core Intel Xeon, 2 x ATI Radeon HD 5770 1 GB

Same issue here, specs: MacOS 10.13.1, Macbook Pro 15" (early 2011)


i had the same issue but it was because of an incompatibility with my mac 10.13.3.
i tried to download 4.9.2 version and that one crashed, so i downloaded 4.15.3 and it was ok!
i hope that this will help you

did you find a solution

I even tried to download Unreal source code and recompile it myself: it goes beyond my skills, I had no luck. Too bad cause I largely prefer Unreal over other Game Engines, but looks like Epic decided for us what hardware to use. Wierd because my MBP early 2011 (upgraded with an SSD) is still a decent dev machine.