Download

Editor crashes on compile

Hi guys,

I have some serious issues compiling my code.
I’m on 4.15.0 with Visual Studio 2015.

First of all, most of the time (like 98%) i have to rebuild the whole solution, because when i just build it, following error occurs:



ERROR : UBT error : Failed to produce item: C:\Users\jochen\Documents\Unreal Projects\Atmosphere\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Atmosphere-371.lib

Failed to produce item: C:\Users\jochen\Documents\Unreal Projects\Atmosphere\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Atmosphere-8033.lib	Atmosphere	C:\Users\jochen\Documents\Unreal Projects\Atmosphere\Intermediate\ProjectFiles\ERROR	1	

Error	MSB3075	The command ""C:\Program Files\Epic Games\UE_4.15\Engine\Build\BatchFiles\Build.bat" AtmosphereEditor Win64 Development "C:\Users\jochen\Documents\Unreal Projects\Atmosphere\Atmosphere.uproject" -waitmutex" exited with code 5. Please verify that you have sufficient rights to run this command.	Atmosphere	C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets	41	

This only happens when Unreal Editor is opened i guess.
I only have a small test project with a single actor-derived class, the map is just the default with my actor added, nothing special here.
Rebuilding the whole project takes around 40s on my machine, which is a pain in the *** when you need to do that after every small change.

But on top of that, Unreal Editor keeps crashing without an error message on hot reload or when the above error occurs, so nearly everytime i compile.
It’s happening when i press “compile” inside the editor.

Am I doing something essentially wrong here?

Well i found a temporary solution…
I let UE start by Visual Studio Debugger. This way I don’t get the mentioned error and can just “build” instead of “rebuild” every time.
But I have to wait for UE to start up every time and when I forget to save changes before stopping or restarting the debug session everything is wiped out.

I wonder if I’m the only one getting this error and the crashes.
I’ve just started with Unreal, Windows is just a month old and I have just a single class in the project.

P.S.: I update to 4.15.1 meanwhile

I’ve always had issues like this too.

  • The Editor’s Compile button just doesn’t work anymore to me, always fails to compile, but compilling inside visual studio works as intended, so I can’t trust that button anymore :stuck_out_tongue:
  • Sometimes I can’t compile visual studio with the editor open. But as I said: sometimes.
  • The editor seems to crash (sometimes) if you edit and compile a class you have open at the editor. This makes sense, since it should get updated somehow.

All these things brothers when developing, but we always seem to find a workaround :rolleyes:. Would be interesting to have a thread adressing all this kind of issues.

On my new project the error is gone, which is kind of strange because I didn’t change anything else…

I don’t have visual studio open (using editor only) but I’ve been getting crashes on compile often since 4.15 update. I had the problem with the gamestate bp, I solved it by replacing the bp with an old (although duplicate) version of the gamestate bp. Currently having the same issue with the player controller bp but the replacing of the file with an old version doesn’t appear to be working this time (the unreal editor doesn’t even start just crashes at 45% load). Interestingly if I duplicate the blueprint with a new name it works fine, but as soon as I name it back to it’s original name (I have a full game of castings relying on that name) it can’t compile again.

Another notable compile quirk…ever since 4.15.1 update I have to re-compile a couple of my widgets every time I start up the editor. Compiling and then saving doesn’t solve, those same bp’s need to be re-compiled again before playing in editor. It doesn’t say why they need to be compiled, just requires a press of the compile button (these don’t crash editor however).

For what it’s worth my problem is very similar to this: Blueprint reference bugged out - UE4 AnswerHub . Going to try manually re-directing everything to the duplicate version that works.

Got it to compile, the problem was coming from one of those “notable compile quirks” I mentioned in the widget blueprints. I deleted those widgets and the player controller bp compiled after that. I guess one of those widget files got corrupted somehow. The bp’s weren’t being used and play in editor wasn’t effected. Anyway it’s working now. Not sure if my issue helps topic creator but keep in mind that the blueprint that the engine crashes on may not necessarily be where the corruption is deriving. It could be coming from a blueprint referencing the one the editor crashes on.