Editor crashes continuously

My editor crashes continuously. It crashes at random times, for random actions (such as right clicking to open menus). Now I cannot hit Play anymore since it crashes immediately every time I do it.

I have been using UE for just a week, and I am currently handle a very simple project. I have less than 20 objects in the world and just a couple of C++ classes with almost no code in them.

I tried to delete temporary files and regenerate VS project files multiple times. I tried to delete data from AppData folder, but nothing changed.

I am on a dell xps 15 9570 with an integrated card and a gtx 1050 Ti. Windows 10. Not a lot of free space on disk (9 GB remaining). 16 GB ram. Nvidia drivers up to date.

I’ve had problems in the past with my Nvidia gpu (which I still couldn’t figure out thanks to a terrible assistance), therefore I am usually avoiding to use it when playing heavy games. For Unreal, I am on Optimus (which I guess should make UE use the gtx card) since I don’t know exactly how to make my computer use just the integrated card for Unreal (I don’t know exactly on which executable to set it).

From my crash logs, I paste here some snippets which may give hints on possible crashes reasons (I wasn’t able to solve the problem myself with this information):

Always on top

LogWindows: Failed to load 'aqProf.dll' (GetLastError=126)
LogWindows: File 'aqProf.dll' does not exist
LogWindows: Failed to load 'VtuneApi.dll' (GetLastError=126)
LogWindows: File 'VtuneApi.dll' does not exist
LogWindows: Failed to load 'VtuneApi32e.dll' (GetLastError=126)
LogWindows: File 'VtuneApi32e.dll' does not exist
LogConsoleResponse: Display: Failed to find resolution value strings in scalability ini. Falling back to default.

Sometimes at the bottom

[2019.02.20-21.32.54:904][ 67]PIE: Play in editor start time for /Game/UEDPIE_0_NewMap -0.059
[2019.02.20-21.32.54:905][ 67]LogBlueprintUserMessages: Late PlayInEditor Detection: Level '/Game/NewMap.NewMap:PersistentLevel' has LevelScriptBlueprint '/Game/NewMap.NewMap:PersistentLevel.NewMap' with GeneratedClass '/Game/NewMap.NewMap_C' with ClassGeneratedBy '/Game/NewMap.NewMap:PersistentLevel.NewMap'

Sometimes at the bottom

[2019.02.20-20.54.01:318][700]LogD3D11RHI: Error: Result failed 
 at D:\Build\++UE4\Sync\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Query.cpp:140 
[2019.02.20-20.54.01:318][700]LogD3D11RHI: [Aftermath] GDynamicRHI=00000173B8378100, GDX11NVAfterMathEnabled=0, Result=0xFFFFFFFF, bDeviceActive=0
[2019.02.20-20.54.01:318][700]LogWindows: Windows GetLastError: The operation completed successfully. (0)

Any help is appreciated :frowning:

I’ve had issues with latest Nvidia drivers and had to rollback. Have you tried v.418.81 ?