Editor crash on map load

Trying to load up my scene and it keeps crashing Unreal editor,scene was working fine earlier. The error report mentions vegetation- my scene is vegetation heavy but I haven’t changed the procedural vegetation in a few days (not added to it or re-simulated) and it wasn’t crashing before.

Unknown exception - code 00000001 (first/second chance not available)

"Assertion failed: !Cache.InstanceBaseInvMap.Contains(BaseInfo.BasePtr) [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\Foliage\Private\FoliageInstanceBase.cpp] [Line: 240]

UE4Editor_Core!FDebug::AssertFailed() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\misc\outputdevice.cpp:374]
UE4Editor_Foliage!FFoliageInstanceBaseCache::CompactInstanceBaseCache() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\foliage\private\foliageinstancebase.cpp:241]
UE4Editor_Foliage!AInstancedFoliageActor::PostLoad() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\foliage\private\instancedfoliage.cpp:2425]
UE4Editor_CoreUObject!UObject::ConditionalPostLoad() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\coreuobject\private\uobject\obj.cpp:723]
UE4Editor_CoreUObject!UObject::PostLoadSubobjects() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\coreuobject\private\uobject\obj.cpp:744]
UE4Editor_CoreUObject!UObject::ConditionalPostLoadSubobjects() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\coreuobject\private\uobject\obj.cpp:812]
UE4Editor_CoreUObject!UObject::ConditionalPostLoad() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\coreuobject\private\uobject\obj.cpp:720]
UE4Editor_CoreUObject!EndLoad() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:1286]
UE4Editor_CoreUObject!LoadPackageInternal() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:1042]
UE4Editor_CoreUObject!ResolveName() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:681]
UE4Editor_CoreUObject!StaticLoadObjectInternal() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:768]
UE4Editor_CoreUObject!StaticLoadObject() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:832]
UE4Editor_ContentBrowser!FAssetData::GetAsset() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\assetregistry\public\assetdata.h:208]
UE4Editor_ContentBrowser!SContentBrowser::OnAssetsActivated() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\editor\contentbrowser\private\scontentbrowser.cpp:1737]
UE4Editor_ContentBrowser!TBaseSPMethodDelegateInstance<0,SContentBrowser,0,TTypeWrapper cdecl(TArray const & ptr64,enum EAssetTypeActivationMethod::Type)>::Execute() [d:\buildfarm\buildmachine++depot+ue4-releases+4.10\engine\source\runtime\core\public\delegates\delegateinstancesimpl_variadics.inl:282]
UE4Editor_ContentBrowser!TBaseSPMethodDelegateInstance<0,SContentBrowser,0,void cdecl(TArray const & ptr64,enum EAssetTypeActivationMethod::Type)>::ExecuteIfSafe() [d:\buildfarm\buildmachine++depot+ue4-releases+4.10\engine\source\runtime\core\public\delegates\delegateinstancesimpl_variadics.inl:388]
UE4Editor_ContentBrowser!SAssetView::OnListMouseButtonDoubleClick() [d:\buildfarm\buildmachine
UE4Editor_ContentBrowser!TBaseSPMethodDelegateInstance<0,SAssetView,0,TTypeWrapper cdecl(TSharedPtr)>::Execute() [d:\buildfarm\buildmachine++depot+ue4-releases+4.10\engine\source\runtime\core\public\delegates\delegateinstancesimpl_variadics.inl:282]
UE4Editor_ContentBrowser!TBaseSPMethodDelegateInstance<0,SAssetView,0,void cdecl(TSharedPtr)>::ExecuteIfSafe() [d:\buildfarm\buildmachine++depot+ue4-releases+4.10\engine\source\runtime\core\public\delegates\delegateinstancesimpl_variadics.inl:388]
UE4Editor_ContentBrowser!TBaseDelegate >::ExecuteIfBound() [d:\buildfarm\buildmachine
UE4Editor_ContentBrowser!SListView >::Private_OnItemDoubleClicked() [d:\buildfarm\buildmachine
UE4Editor_ContentBrowser!STableRow >::OnMouseButtonDoubleClick() [d:\buildfarm\buildmachine
UE4Editor_Slate!::operator()() [d:\buildfarm\buildmachine
UE4Editor_Slate!FEventRouter::Route >() [d:\buildfarm\buildmachine
UE4Editor_Slate!FSlateApplication::ProcessMouseButtonDoubleClickEvent() [d:\buildfarm\buildmachine
UE4Editor_Slate!FSlateApplication::OnMouseDoubleClick() [d:\buildfarm\buildmachine
UE4Editor_Core!FWindowsApplication::ProcessDeferredMessage() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\windows\windowsapplication.cpp:1358]
UE4Editor_Core!FWindowsApplication::DeferMessage() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\windows\windowsapplication.cpp:1721]
UE4Editor_Core!FWindowsApplication::ProcessMessage() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\windows\windowsapplication.cpp:719]
UE4Editor_Core!FWindowsApplication::AppWndProc() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\windows\windowsapplication.cpp:641]
UE4Editor_Core!FWindowsPlatformMisc::PumpMessages() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\windows\windowsplatformmisc.cpp:884]
UE4Editor!FEngineLoop::Tick() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\launchengineloop.cpp:2391]
UE4Editor!GuardedMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\launch.cpp:142]
UE4Editor!GuardedMainWrapper() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
UE4Editor!WinMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\windows\launchwindows.cpp:200]
UE4Editor!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264]

Hello vagrantart -

Can you please make sure to submit your report through the crash reporter and take note of the Machine ID listed and please post that ID here?

Thank You

Eric Ketchum

I didn’t save a version of the crash report but did submit it at the time so dont have the machine ID unless there’s another way to get it,I reverted to an older save so no longer have version that was crashing.

Hi -

You can open any project and open the Console Command by pressing the ~ key. then type in “debug crash”. This will force the engine to crash and you can get the Machine ID from that location.

Thank You

Eric Ketchum



Hi vagrantart -

I think that this might be related to a GUID duplication happen in the project, can you post a copy of your project logs here, you are not sharing them via Crash reporter.

I also think that this might be corrected in 4.11, so if you can make a copy of your project and try to open it in 4.11 Preview to test to see if the crash still occurs. If it does please make sure to submit the crash and if not let us know as well.

Finally, I am attempting to generate a sample project which replicates the crash, but if you can give me any additional information about your project setup and specifically your Foliage setup or if you are able to replicate the conditions in a sample project and get the crash you can post that here.

Thank You

Eric Ketchum

I had a look for the logs and seems I have deleted them,I cleared out the cache which was 19gb! also (I had been checking out a lot of the demo scenes) and I reverted to an older save file so recovering it isn’t important (would still be good to know what caused it though) and will update to 4.11 also.

My project set-up was a 2k map using procedural vegetation and landscape auto material,only 5/6 variety’s of plants were added.The only potential error I saw in the editor before the map file corrupted or crashed was that the terrain painting tools didn’t seem to work at one point. I’m using all the same assets and set-up in current map version and the problem hasn’t happened again (yet).

EDIT - it crashed again,submitted crash report with the logs this time. This time it happened specifically when I increased the manual foliage brush size and painted.I had 5 instances of plants loaded and low density set after a few seconds of adding the plants it crashed and the map cant be loaded now,luckily I made a backup save 10mins before this time.

Hey vagrantart,

I am assuming when you say ‘procedural vegetation’ you are using the LandscapeGrassType node within the material editor to define where the foliage is placed, in combination with the foliage paint tool to hand paint the foliage as well?

I want to try and reproduce your crash on my end, so gathering all the accurate information to get the crash to occur is going to be really helpful. For a more accurate test, which might not be the best option since it sounds like your project is rather large, you can zip up your exisitng project and share it with me via a private message after uploading it a shareable drive like Google Drive or Dropboxx.

You mention that a potential clue to the crash occurring is your landscape painting tools stopped working. If you could get me to this point, that might allow me to get the crash to occur on my end as well.

Thank you,

I was using foliagetype node and hand painting (wasn’t actually using the procedural vegetation).I tried re-producing it myself and couldn’t on an empty scene,think its caused by the foliage settings I had originally set up when I was just going to populate the map procedurally.
When I set foliagetype node to default the problem doesn’t happen so maybe I just mixed the wrong values somewhere and it causes a problem when I using a bigger brush to paint them.

Ok, I appreciate you taking the time to test this in a blank project.

Could I get some screenshots of your material editor using the nodes you mentioned, as well as the foliage settings of the project you are experiencing issues?

Most of the foliage had these same settings,and this is also terrain info.The trees are from the lake side cabin pack.
It usually crashes when the paint brush goes over 500.00 -ish in size

I have attempted to reproduce the crash you are experiencing using the Foliage Type settings you have applied, but did not get the crash to occur.

I will say the settings you are using in your Foliage Type asset are a bit extreme, as when I attempted to paint using the foliage, it was incredibly dense and caused my computer to slow down a lot!

Is there a way you could provide me with your project so I can test this on my end using your specific set up?

Zip up your Content, Config, and .Uproject files/folders and upload them to an external file sharing drive like DropBoxx or Google Drive. You can then send me a private message on the forums with the link so I can download and test on my end.

Let me know if you have any questions.


My project size is too large for dropbox to upload. Since I know it’s the brush size I will probably replace the foliage with something with less dense settings and shouldn’t be a problem.Thanks for the help.

Any progress? I have exactly same problem, the app crashed at “FoliageInstanceBase.cpp Line: 240” when I loaded a map. It happened once a week ago, I fixed it by reverted the map to an older version. Today, it happened again. I have sent report with log.


FYI, I tried 4.10.4 and 4.11.2, all no luck.

FYI, I just “reproduced” it once though cannot every time, I highly doubt it caused by one of…

  1. I digged some “holes” on the landscape by “Delete” tool from the “Manage” panel.
  2. I am used to backup map by “Save As” to another map name but without making a copy of “xxx_sharedatasets” folder, then somehow I opened and edited one of “older” map with newer “xxx_sharedatasets”.

As I mentioned in previous posts, I need a reproduction case in order to report this bug. If you are able to get me a test project or narrow down some repro steps, I will be glad to investigate further.