Download

Editor crash on launch even after clean reinstall (mac)

Editor wont start (empty editor, no project), not through launcher and not through app directly.

Error msg states cant find /Users/build/…/SharedPointer.h and indeed I dont have a /Users/build folder at all.

Tried:

  • verifying, reinstalling engine (twice), including launcher, with restarting computer
  • removed all files with cleaner tool
  • verified and updated xcode
  • removing, and then separately readding some engine options (build platforms, that kinda stuff)
  • deleting DerivedDataCache (Users>Shared>UnrealEngine>[Engine Version]>Engine>DerivedDataCache)

No luck.
How to fix? Thanks. [HR][/HR]
Full error msg:


Assertion failed: IsValid() [File:/Users/build/Build/++UE4+Licensee/Sync/Engine/Source/Runtime/Core/Public/Templates/SharedPointer.h] [Line: 890]

FGenericPlatformMisc::RaiseException(unsigned int) Address = 0x10a136797 (filename not found) [in UE4Editor-Core.dylib]
FMacErrorOutputDevice::Serialize(char16_t const*, ELogVerbosity::Type, FName const&) Address = 0x10a2cda33 (filename not found) [in UE4Editor-Core.dylib]
FOutputDevice::LogfImpl(char16_t const*, ...) Address = 0x10a3b25e9 (filename not found) [in UE4Editor-Core.dylib]
AssertFailedImplV(char const*, char const*, int, char16_t const*, __va_list_tag*) Address = 0x10a3325fe (filename not found) [in UE4Editor-Core.dylib]
FDebug::CheckVerifyFailedImpl(char const*, char const*, int, char16_t const*, ...) Address = 0x10a332494 (filename not found) [in UE4Editor-Core.dylib]
FInputBindingManager::CreateInputCommand(TSharedRef<FBindingContext, (ESPMode)0> const&, TSharedRef<FUICommandInfo, (ESPMode)0>) Address = 0x112d7f980 (filename not found) [in UE4Editor-Slate.dylib]
FUICommandInfo::MakeCommandInfo(TSharedRef<FBindingContext, (ESPMode)0> const&, TSharedPtr<FUICommandInfo, (ESPMode)0>&, FName, FText const&, FText const&, FSlateIcon const&, EUserInterfaceActionType, FInputChord const&, FInputChord const&) Address = 0x112d764ab (filename not found) [in UE4Editor-Slate.dylib]
MakeUICommand_InternalUseOnly(FBindingContext*, TSharedPtr<FUICommandInfo, (ESPMode)0>&, char16_t const*, char16_t const*, char16_t const*, char const*, char16_t const*, char16_t const*, EUserInterfaceActionType, FInputChord const&, FInputChord const&) Address = 0x112d75d3a (filename not found) [in UE4Editor-Slate.dylib]
FGenericCommands::RegisterCommands() Address = 0x112d77674 (filename not found) [in UE4Editor-Slate.dylib]
TCommands<FGenericCommands>::Register() Address = 0x112d2a090 (filename not found) [in UE4Editor-Slate.dylib]
FSlateApplication::FSlateApplication() Address = 0x112d28cc0 (filename not found) [in UE4Editor-Slate.dylib]
FSlateApplication::Create(TSharedRef<GenericApplication, (ESPMode)0> const&) Address = 0x112d27563 (filename not found) [in UE4Editor-Slate.dylib]
FSlateApplication::Create() Address = 0x112d273f8 (filename not found) [in UE4Editor-Slate.dylib]
FEngineLoop::PreInitPreStartupScreen(char16_t const*) Address = 0x109d42e40 (filename not found) [in UE4Editor]
GuardedMain(char16_t const*) Address = 0x109d3943d (filename not found) [in UE4Editor]
-[UE4AppDelegate runGameThread:] Address = 0x109d55fcf (filename not found) [in UE4Editor]
-[FCocoaGameThread main] Address = 0x10a2a0331 (filename not found) [in UE4Editor-Core.dylib]
Unknown() Address = 0x7fff301fb7a2 (filename not found) [in Foundation]
_pthread_start Address = 0x7fff67e08109 (filename not found) [in libsystem_pthread.dylib]
thread_start Address = 0x7fff67e03b8b (filename not found) [in libsystem_pthread.dylib]

Somewhat fixed by installing a prior version of the engine (as I suddenly couldn’t get 4.25 to run anymore, I installed 4.24 and it works). I suspect I will be able to install and run 4.25 again now, but either way that single version point difference doesn’t matter to me that much, and besides, I will be able to upgrade engine version later anyway.

Yeah, still doesn’t work. Not a terrible concern, since I have a point prior version working, and I will upgrade to 4.26 when it’s out of preview. It’s bugging me having some files somewhere on computer not working, so I’d still be interested in how to fix this.

What are your system specs? Are you running the latest version of OSX?

Yep, latest version. Not to get into specs, it worked and then it suddenly didnt. Like editor crashed after several days of work and was not able to start up again. 4.24 works.