Editor Closes when Opening Map


Just 2 days ago, I was editing my map fine on 4.22. I closed it, and the next time I tried to open the project, it would load to 75% and just close itself with no crash report.

To try to solve this, I upgraded the project to 4.23 (as a copy) and the project can now open on the default project map (which is a different map from what I was editing), but whenever I try to open the map I was working on, the editor closes itself without any crash report.
Even if I right-click on the map in the Content Browser, it would load for a while and then the editor would close.

I have tried looking for any leads some logs (Project/Saved/Logs) but could not find any useful information.
I also have not set up source control for this project.

Can anyone help me?

I have exactly the same problem right now, is there anyone can answer that?

I resolved this by deleting the entire engine and then redownloading & reinstalling. Not sure what caused this but, I hope it resolves your issue as well.