Editor becomes unresponsive after gameplay

Engine version 4.13.2
Windows 10
Oculus software installed (the software starts by itself whenever I start the editor, issue persists even if I close it)

Lately I’ve been having an issue with the editor, after starting the game in standalone mode, sometimes the editor becomes unresponsive, meaning that if i click on it on the start bar it doesn’t come into focus, whenever it is in view I can’t interact with the editor at all, it’s like a frozen picture.
In the task manager is listed normally and not as unresponsive, the only way to get out of it is to force close it through the task manager.
The issue happens very often and it happens in multiple projects

Hello DoubleP90,

I have a few questions for you to gather some more information

  1. Is this only occurring in your existing projects or even in fresh, empty ones?
  2. Have you had this issue with any other versions of the editor or just with 4.13.2?
  3. Could you provide your Dxdiag so that I can tell what kind of setup you’re using?
  4. When you look at the Task Manager while it is frozen, are there any particular fields that are very high in usage such as Memory or Disk?
  5. When you go to close the editor with the Task Manager, do you ever get a message from Windows saying that the program has stopped responding after hitting End Task? If so, please follow this tutorial to get your Windows Event Viewer logs. They may be able to give us some useful information.
  6. Can you provide the Log files (ProjectName/Saved/Logs/ProjectName-Log.txt) from one of these sessions where the editor has frozen?
  7. In regards to the Oculus software you mentioned, is an Oculus device plugged into the PC when you open the editor? If so, this is expected and occurs with most, if not all, Oculus applications, last I heard.
  1. This is occuring with multiple projects, with varying frequency, seems not to be happening with a fresh project
  2. Issue is only present in 4.13.2
  3. When getting the Dxdiag I get the following error “Dxdiag has detected that there might have been a problem accessing DirectShow the last time this program was used. Would you like to bypass Directshow this time?”, the file after bypassing DirectShow is attached in the link
  4. CPU usage around 10% (changing all the time, around that value), Memory 939.8MB (value doesn’t change through the duration of the freezing), Disk 0.1MB/s (value doesn’t change through the duration of the freezing)
  5. No, the editor just closes
  6. Dropbox - Logs.zip - Simplify your life
  7. Yes it is plugged in, probably it’s not the cause of the problem because I get this issue even when it doesn’t start, it’s something new I added to the system so it was worth mentioning

Additional info: Rarely the editor freezes whenever I use another program, seems like the freezing is related to it going out of focus.
This happens when using other programs or other editor instances (different project), cannot replicate this though, testing the game in standalone makes it happen in a few tries

Lately whenever the editor was out of focus it would randomly start flashing orange in the windows start bar for no reason, maybe it’s a related issue

The first thing that I notice from the logs is that the last thing that occurred before the crash was an auto-save and it tried doing something else but was stopped in the middle of writing the log message. Although this is definitely not a suitable workaround, could you try temporarily disabling autosaves to see if it’s related to the freezing?

Also, this likely isn’t related, but I noticed this warning from your log:

K2Node_CallFunction_3175 is deprecated; Use the new version of Set Input Mode Game And UI instead

This is referring to the LobbyPC blueprint. It seems like something that comes from converting from a previous version of the engine. Can you try resolving this? It should just require deleting the node and then readding it so that you get the non-deprecated version.

None of the 2 solutions fixes the problem, I tried again with a fresh project (third person) and I managed to make it freeze aswell, so I’m gonna speculate that it’s an engine issue rather than project related

EDIT: correction, the issue is happening in 4.12 aswell

After speaking with another team member, they mentioned that they’ve also had a report of this issue from a few other users. In that thread, a user found out that this seems to be an issue caused by Nvidia’s share settings in the Nvidia GeForce Experience program. You can find more about that here:

Can you try disabling the share feature in Nvidia GeForce Experience and see if it may fix the issue?

Great :smiley: this seems to have fixed the issue.
I’ll see with usage if the fix works or if it’s one of those times where i get lucky and can’t force freeze it