Editor always opens up in 1930x1080

So for some reason the editor started doing this since 4.3. I have two monitors at 1920x1080 each and the editor always opens up on the primary one with the above mentioned weird resolution. It does not remember the previous resolution (1920x1079 so it doesn’t hide the taskbar), nor does it seem to find this weird.

Anyone got a clue or a solution to this problem? The scrollbar on the right is always cut off when the editor starts…

Engine Version: Source from branch ‘promoted’ built using Visual Studio 2013 Ultimate (last stable patch)

Hello Xaymar,

I was unable to reproduce your issue on my end. I have a few quick questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you tell me what version of the engine it is that you are using?
  2. Does this happen with all projects?
  3. Is this a project that has been upgraded to newer versions since 4.3?

Hello Rudy Triplett,

I have absolutely no idea what even started causing it. I went through a complete system reinstall (once a year, 01.01.2015 marks the rebirth of this system) since then and it still happens. Hardware is still (mostly) the same as here, GPU2 was removed though.

Quick answers:

  1. It says 4.8.0 but I’m pretty sure it’s 4.7.0 preview (built from Source branch promoted). This happens on the binary builds too.
  2. Yes, even marketplace ones and freshly created ones.
  3. No, this is a fresh project. Upgrading an older project doesn’t change the behaviour either.

Hello Xaymar,

I would like you to clarify a couple of things please.

  1. When you say that the editor comes up and does not remember the size. Are you referring to the actual editor or the project selection window?
  2. What method are you using to resize your window?
  3. Where exactly are you launching it from?
  4. Can you provide a screen shot of the issue?

Hello Rudy Triplett,

sorry for the slow answer, I had to fix a critical failure bug with the mail server. Here’s the information you need:

  1. It’s the editor window itself, not the project selection.
  2. I tried dragging the border (normal resize), using WindowActions (forced resize) and dragging the window to the left/right side of the screen to make it fill (aero resize).
  3. Tried from launcher, project file and using the executable (D:\Projects\Cpp\UnrealEngine\Engine\Binaries\Win64\UE4Editor.exe)
  4. From LudumDare31 (Same for any project though, it’s always the right part being cut off.)

Hello Xaymar,

I am still unable to reproduce this issue on my end. Have you changed any display settings inside of the editor or windows? I know that changing the DPI scale of your text for windows can have a similar issue, though not to the extreme as that shown in the picture provided in your post.

Hello Rudy Triplett,

I changed the smooth framerate range to 30…Open if that could have been the cause, otherwise I didn’t touch anything. I wish I knew what started causing this and why it won’t stop.

Hello Xaymar,

Does this happen with any other software on your computer?

Hello Rudy Triplett,

unfortunately not, that would make it easier to track down. It’s only Unreal Engine that has this, no matter what project I open.

Edit: What might be of worth noting is that I had Unreal Engine once in fullscreen when it crashed during that. That was about the time the issues appeared and didn’t want to go away again.

Hello Xaymar,

These may sound like questions with an obvious answers, however they will narrow things down even so.

  1. Have you tried opening the editor on another computer entirely?
  2. Have you experienced crashes since then with the editor window in a different position or size?

Hello Rudy Triplett,

  1. Yup, it is only this computer being affected by it, no other computer shows this problem. I tried to run it in a VM clone of this machine and it happens too.
  2. Also yes, after closing(crashing) and reopening, the Editor will be back on the primary monitor, while all other windows open on the secondary monitor in the same 1920x1030 resolution.

Hello Xaymar,

I was digging around in the configuration settings for the projects and I found the file that sets the window size. Could you send me your “EditorUserSettings.ini” file so that I can take a look at them?

The default directory is:
C:\Users*YourUserName*\Documents\Unreal Projects*YourProjectName*\Saved\Config\Windows

Steps to take for a possible workaround:

  1. Open “EditorUserSettings.ini” in notepad
  2. Press Ctrl+F (this will bring up a search window)
  3. In the little search window type “RootWindow”(without the quotes)

  1. Set the position and size by changing the numbers in the highlighted area

Please let me know if this allows you to change your default window size.

A couple of tests for you to run would be:

  1. Try changing the settings manually (as listed above) to see if the changes are applied.
  2. Change the window size as you normally would (clicking and dragging the edges) and then close the window. Then open the EditorUserSettins.ini again and see if the settings were saved.

Hi Rudy Triplett,

here is the requested EditorUserSettings.ini from one of the affected projects. I noticed after following your tutorial that the WindowSize parameter is stuck at 1960x1080 and not 1930x1080 like windows sets the window size to. I’ll try manually changing it after I’m done updating my local source build.

Hey again Rudy Triplett,

I tried both your suggested solutions, without success. Neither solution changed the initial position and size of the Editor. Has this really never occured to anyone at Epic Games? It seems way too strange to not have appeared at all, maybe I can find out myself what is causing it if I knew where the size of the window was calculated and set (wee debugging!).

Hello Xaymar,

To my knowledge this has not occurred on our end. Could you send us the Change list for the version of the engine you are currently using. I notice you said that it was the latest stable patch. But I would like to be able to test everything under the same circumstances. The easiest way to found out your change list is to go to “Help” in your editor tab and at the bottom you should see “About Unreal Editor”. You will see something like this:

29900-abouthelp.png

Hello Rudy Triplett,

sorry for the late reply, I was on vacation so I didn’t have Unreal Engine with me.

I switched to the prebuilt-binaries while I’m not working on my plugins and extending the engine, so right now I’m using this build: http://i.imgur.com/IUiLv3x.png .
The source build is recompiling as I write this, might take some time.

Hello Rudy Triplett,

I got the Source build to compile now, it’s the following version: http://i.imgur.com/bLDcsl . It seems to work fine with this version, so I hope it’ll be fixed in the binary builds too.

It seems that 4.7.1, both binary and source, have the issue resolved. Finally I can edit in peace without the right side being cut off. Thanks!

Issue has been fixed in 4.7.1 (promoted/release on Github).