Dynamic Shadows broken in 4.23

So today I tested out how dynamic lighting only is in 4.23 and I noticed that dynamic shadows now give very inconsistent results, and on the landscape terrain they seem completely broken.

As can be seen in this picture, this shadow is not right.

It’s easily reproducable: add a landscape terrain to your level, sculpt some mountains near the edge and rotate your directional light till you see long shadows. And there is nothing I can do in the light settings to prevent this.

Oh no! Have you reported it yet? I’ll escalate from here.

Thanks for reporting the issue. To me it looks like the behavior is due to the back face culling happening on the terrain mesh. I’ve tried to reproduced your case, and I don’t see any behavior difference between 4.22 and 4.23.

Are you running with some special options/console variables?

this still isn’t fixed… shadows are neat. far shadows are getting culled based on landscape component size and position. shader es31.

check to see there isn’t a giant banner in the sky?

How stupid do you think I am?

“How stupid do you think I am?”

It was a joke, trying to relate through humor. Sorry. Really odd issue. I’ve had issues with dynamic lighting and shadows in 4.23 too.

Oh, sorry then my reaction was harsh, it didn’t come across as a joke.

And yeah, sadly dynamic lighting is still a huge problem even in 4.24 :frowning: What problems do you have? You can write it down in this discussion: Dynamic shadows artifacts - Unreal Engine Forums

It’s best to keep it up so Epic can’t ignore it for another two years.

Well, in one level I was working in (3rd person shooter template), I added a colored glass material to a few of the platforms. Wherever the face of a grey (default color) platform meets the face of a glass platform (from the material I applied), there’s a ton of flickering and artefacts (jittering lines and aliasing). I tried different settings changes, and it didn’t remove it. Rebuilt lighting, increased resolutions, set all involved to movable…still there…only seemed to be a little bit less via increasing resolution I think. So, I tried enabling ray tracing in the project settings, with ComputeSkinCache, and now I can’t even open the project since it crashes during loading phase.

LIghting is a VERy difficult thing to get right, people say it all the time so keeping lightmap res low till ship is a good idea. I have the flicking in areas and its where there is a long thin ‘light’ that shine on areas of terrain, tho atm I don’t know how to stop it just yet,prob. clashing lights, settings here or there…light is just a PITA everybody knows it, depending of course on what kind of scene you have etc. True especially with large worlds.

For now preston just disable ray tracing in project settings and it will force a restart and you’ll likely be fine. Sounds like, as many of us, join the crowd, you’re prob running out of ram ? Increasing lightmap resolution is another good way to crash depending on scene complexity.

Yeah, I disable ray tracing now, even in asset details panels…though don’t go through everything and do it because I want to see if there’s a difference, plus a quicker way to change properties en masse. I have narrowed one problem with shadow lines type artefacts down to direct lighting and dynamic shadows. When I disable dynamic shadows, the lines disappear completely on all geometry surfaces (faces). When I isolate to exclusively enable direct lighting (no indirect), the lines become darker and more distinguishable. I’ve also noticed that shadow edge resolution (so the shadows at their edges, or casting from the edges of objects such as the top of a wall with no ceiling) is not sharp with dynamic shadowing. I’ve tried turning off AO, changing Post Process Volume settings, Lightmass in World Settings, World Settings, resolution of lightmaps in meshes and lights, modifying the skylight properties and directional light properties (such as Shadow Bias and lots of other ones, in isolation or a few simultaneously), and changing Engine Scalability settings to higher for shadows…but not anything is working. I’ve seen better graphics / shadows in PS2 games and old PC games! What’s the big idear?!

Anyhow, I think Unreal Learning needs updating with tutorials on how to build in the basics of fully dynamic lighting for at least Version 4.23 (with notes on Versions 4.21-24). The documentation also is due for an update to dynamic lighting techniques and practices, and even terminology / settings specific to it. It would probably pre-empt a ton of AnswerHub issues and forum complaints / ‘bugs’ reported, while leveling the field of inquiry regarding the differences between dynamic and static / baked lighting. I switched over from Unity because errors and bugs prevent the play-in-editor function from operating at all. After trying CryEngine, I could tell Unreal is a bit more accessible in certain facets of starting game design, but it really appears to rival Unreal in terms of ease-of-use and supporting doc pages…not also forgetting that it requires lower RAM and processor specs to function.

Thanks for the tips.

I can’t even RUN my large 2x2 world comp world in 4.24.1, even just loading some levels causes crashes, and one end of one map takes alot more fps than the other, figure that one out, and its the same world as here in 4.23, which is also far from perfect. Lighting shouldn’t be this tricky,doable but nobody should have to spend this kind of time .

In both engine versions, I’m getting WEIRD parallel liines of sort only on further out terrain, certainly that’s nor normal.I’ve tried lots of settings can’t get rid of it .

One can HOPE ray tracing with fix all of this nightmare, but then ONLY if you can afford the hardware . Really a disgusting mess,tho engine wise it cant be beat for 3d, noting comes close and Ive tried Lumberyard, cryengine, unity.

Unity is a major pita as it doesnt give you a 3rd person char. out of the box like ue4 does. Talk about greedy! No tuts work either, nor any of the included char.s on store,tho a few comes close,of course for a price, you can prob. get what you want, as most things in life, so on that point and sensibly, Epic is the smartest of them all.

I have projects in Unity and LY , but noted Unity issues make me want to avoid it for now, and LY is a HUGE mess ( tho beautiful ocean) where they force OLD versions of VS. So imho epic has this locked up other than ‘2d’,and not having worked witih it yet, I can’t say if its enough, but I know they don’t seem to be working on it anymore, not sure why entirely.

Anyway ya I’d rather use 4.24.1 for landscape tools etc, but I crash within 5 mins or less, and I’ve posted on it, -zero replies,maybe due to holidays.

IN case you can help with that:


Assertion failed: TessellationFalloffSettings.UseTessellationComponentScreenSizeFalloff == SceneProxy->UseTessellationComponentScreenSizeFalloff [File:D:/Build/++UE4/Sync/Engine/Source/Runtime/Landscape/Private/LandscapeRender.cpp] [Line: 671]


i turned on falloff setting in details on all 4 levels (terrrains, but it made no different .I think its the engine V. gc 4.23 is fine. Sent bug report but I have no sense they’ll respond especially if its my end. SHRUG.