Download

Dynamic Modifiers only Nav Mesh is not working in build

Hello

In our project we used the NavModifier component’s SetAreaClass to change the navmesh at runtime, in order to make certain area accessible to the AI only from a certain scripted point.
We used dynamic modifiers only Navmesh in order to do this, because we want to keep the performance high and we don’t wish to change this.

Everything is working perfectly in Editor and when we play in Standalone starting the game from the editor. We can use the Show Navigation command to see that the nav-mesh get effectively deleted around the NavModifier area.
Anyway the system stop working after launching a build. The NavMesh doesn’t change, doesn’t matter how many time we toggle the component. We are switching to AreaClass_Default to AreaClass_NULL

Is there anyone who happened to have the same problem? As I said, we can’t switch to Dynamic Navmesh in order to mantain performance.

I’ve just run into a very similar situation. Any fix you found? I’ve even tried using Dynamic Navmesh generation and even that doesn’t work with the modifiers. I could probably get around this (probably not actually but hey, let’s be positive) but sadly I’m using instanced levels thus nothing is constant. Navmesh really hates that too so the two together makes for a fun little challenge here and there…

We found out later that the problem was the Engine version itself. Modifiers seem not to be working properly on Unreal Engine 4.22.
We switched to Unreal Engine 4.24 and everything works fine now, but if you can’t, or don’t want, to switch version, I think the only solution is to find the fix on the Unreal Developer Network or by scavenging the Github and applying it yourself.

I am on UE4.24 and I am having problems with dynamic navmesh generation on shipping builds, everything works well in development builds, any thought on that?

Our problem was with dynamic modifiers, not dynamic navmesh. Usally is easier and more performing setting the navmesh to dynamic modifiers only and not entirely to dynamic.
If you still wish to use those anyway, I’ve never tried them on 4.24, but I know that a lot of problem with navigation come from navmesh volumes or recast navmesh which aren’t in the right level (I suggest keeping them in the persistent level).
Try also checking some project settings and default options, having it continuously rebuild can bring a lot of bugs if you have a number levels that are streamed in and out.