Dx12 + ray tracing = video memory crash / memory leak?

Hello, everyone, I have checked the latest quixel scene abandoned apartment on 4,25 but when I try to render the sequencer to see the scene with different cameras, everytime I crash with an “out of video memory trying to allocate rendering resource” message. This only happen with DX12 and not DX11, I tried to DDU and reinstall both Intel and Nvidia driver, I tried to revert windows updates after checking it was the latest, I tried changing the nvidia control panel quite a lot to make it work so far I saw two changes in the last week or 2, first my frame rate on some scene drop from 120 to 60 and the video memory crash.in DX12 with Ray tracing on several project issuing
a video memory crash… any ideas how to fix this apart from opening and working in Dx11 only???. Strange fact when I launch the render I can see the ram running out and the crash happening when it reach 3go could there be a memory leak through unreal? No other programs are open… My config is RTX 2060, I7, 16go on a new Asus Rog laptop. thanks so much for your help!

I have similar config: 7700k + 2060 RTX 16Gb RAM
And similar problem. I updated my windows and nvidia drivers as well as using UE 4.25.3 but it still persist.
I noticed UE4 would render some scenes in ray tracing just fine like ArchViz interior, but others even just enabling it in project settings, keeping everything ray-tracing disabled in postprocessing it would still crash it “out of memory” even though it was relatively simple 8km*8km landscape running at over 170fps prior to enabling ray tracing.

I’m curious if it’s indeed a bug or if it just needs lots of memory…

I am experiencing the same type of thing!

Config: Threadripper 1920X, RTX 2080 Super 8GB, 48 GB system RAM

With DX12 on and ray tracing active (Ray traced reflections and translucency on but with 1 bounce and 1 sample per pixel), my game crashes with “Out of memory trying to allocate rendering resource” at only 3 GB Vram usage. The shared GPU memory usage is high, but still only 11/24 GB.

All my game does is use scene capture component 2D to capture a few frames, nothing crazy.

I know ray tracing uses a lot of VRAM, but this definitely seems like a bug to me.

I’m having the same problem … my first paid project and I couldn’t render anything because of the same error. Movie Render Queue not work. Highresolution Screetshot not work.
I disabled RX12 and gave up raytrace to be able to render and deliver the project on time. But it lost a lot of the quality I wanted.

I am thinking of giving up the Unreal Engine, it was not worth the time and investment and did not meet the deadline. It was close, I risked a lot using Archiviz in this first project.

And now at 4.26, the lightmass GPU has “Error GPU Crashed or D3D Device Removed.”

I tried everything in the forums, nothing resolves. Everything. From the TDR Manipulator, nvidia settings, disable onboard video driver … nothing.

I tried everything.

ya, I just tried opening this map for the first time and this happened


I got the same crash like Peleias. I’m following if someone got the answer…
I have a RTX 2070 8go on my Strix 3 ROG laptop by the way.


I got the same crash like Peleias. I’m following if someone got the answer…
I have a RTX 2070 8go on my Strix 3 ROG laptop by the way.

Same problem with an Alienware laptop with an RTX 2080. Only happens though when I switch to DirectX 12. Raytracing seems to be working with DirectX 11 as well but it seems most of the post-processing effects related to Ray Tracing don’t are not working.