Download

Ducks

I’m proud to announce the release of Ducks on the Unreal Marketplace.

https://youtube.com/watch?v=Y1okXbOMVjw

These Ducks will walk to random Ground Targets taking breaks to feed. They will run then fly away from any Actor with an Enemy Tag. Once in the air they will fly to random Sky Targets (for an adjustable amount of time) after which they will return to the ground. The Ducks also come with Perching behavior and water interaction. Easy setup, just drag some Sky Targets, Perch Targets, Water Targets, and Ground Targets into your level and watch the show. You can also play as a Duck with walking and flying functionality.

Ducks v1.0 Includes:

  • (1) Rigged and Animated Duck Skeletal Mesh (Mallard Duck)
  • (30) Animations
  • (2) Animation Blueprints
  • (3) NPC Character Blueprints with 1 Parent Class (Brown, Green, and White Ducks)
  • (2) Game Modes (Play as the Enemy character and/or play as a Duck)
  • High resolution Textures (4K) and Materials
  • Physics Asset
  • LOD’s
  • Single trace obstacle avoidance while flying and Enemy avoidance while on the ground.
  • Water interaction
  • Behavior Tree and AI Controller
  • Ragdoll on hit
  • Sounds (Duck calls, Splashes, and wing flaps)

Hi,

I buyed the Ducks yesterday but this pack is to heavy, takes forever to only load, then i copied the folder direct into my project and now my project is loading 10 times slower. (basic fresh project with only a landscape in it)
Till now i only got it to be up and running once. after a long time waiting.

So at this point i can not use this pack as it just crashes my projects and my pc CPU goes 100% by only trying to load a new project.

my pc:
Processor: AMD FX™-8320 Eight-Core Processor (8 CPUs), ~3.5GHz
Memory: 16384MB RAM
Available OS Memory: 16284MB RAM

i’m timing: start fresh project 9:18 min end initializing 9:46 min.

The test run once loaded looks and runs ok just the loading gets heavely put down and not just the first time but all the time you load that project.

mvg
Jengske

Sorry for the issues you are having. the issue is that the demo level contains assets from the Kite Demo, very resource hungry assets, I’ll get those swapped out, they look nice but take forever to load.

**UPDATE **I have replaced all the Kite Demo assets and everything is loading much faster now. Let me know if you run into any further issues. :slight_smile:

Hi,

Now it load very quick, i have a small question about the water where the ducks land, i’m using the trueSky water and sky in my project.
By using this water that has no direct way in changing the components on it, only true the details panel i need to find a way to let the ducks land on the water.

What is needed to keep them on there as for now they sink into the water. (If not posible i will use a other water asset for the small rivers and lakes)

mvg
Jengske

I have not used the TrueSky water but after some searching i can see it’s not a still water but a undulating water. I can see why you are having issues. the Ducks work with buoyancy (settings in Character Movement) and a water volume, the same as any other swimming Character. You can also use a blocking volume with a custom collision channel so it only blocks the Ducks. As for the TrueSky water, does it have buoyancy settings? or can it be set to block all? I’m not sure. but these are the kind of things your looking for. In the Ducks demo level I use the Unreal Lakes water with a water volume. Hope that helps.

Hi friend, you did a great job thank you very much!
I am a hunter and want to create AI wild ducks for my game.

Please help:

  1. How can I make ducks not look for “BP_Duck_Ground_TargetPoint”? (Ducks need to land only on water)
  2. How can I make ducks not rotate in flight 360 ° vertically?

  1. Where to turn on the visual display of line trace and change the distance to a collision with an obstacle?

1- To adjust the Ducks to limit their behavior to only sky and water interactions you need to make the following changes to the “BP_BTTask_Duck_RandomBehaviorSelector” (found here- Ducks > AI > Tasks folder)
Find this section-

](filedata/fetch?id=1782395&d=1593463470)

Make These Changes- Don’t miss that random int node (Important)

](filedata/fetch?id=1782397&d=1593460497)

2- I think you are referring to the pitch adjustment here- open the “BP_BTService_Duck_ObstacleAvoidance” (found here- Ducks > AI > Services folder) and adjust the following section

](filedata/fetch?id=1782398&d=1593461356)

3- You can draw the avoidance lines by opening the “BP_BTService_Duck_ObstacleAvoidance” (found here- Ducks > AI > Services folder) and edit the following section

](filedata/fetch?id=1782396&d=1593463487)

You can also define how long you want the obstacle avoidance trace lines to be in the “BP_NPC_Duck_Base” (found here- Ducks > ParentClassBlueprints folder) change the “down trace distance” variable to whatever you like.

I hope that was helpful :slight_smile:

Just purchase ducks, How do create the “Water_ PhysicsVolume”, can’t find this item, thanks dennis

Thanks for supporting Ducks! :slight_smile:
So to add a water volume you just need to drag a plain “Physics Volume” into your level, then in the details panel under “Character Movement” check the “Water Volume” Bool.

Thanks for the fast reply, worked great

Hi,
I bought the Ducks asset and it all works really nicely out of the box - I dragged in some sky and water targets and a few ducks and they all randomly do their stuff. Really nice!

I want to control the ducks somehow - at night I want them all to ‘go home’ and then come back when the sun comes up.

I could move all the duck targets off the map at night and put them back in the morning, but thought I would see if there is a better way to do this.

Thanks