Download

Dropping texture on material crashes UE5

Hey there,
first and foremost this is about UE5, I added the 4.27 tag because it didnt let me post without it. For some reason it kept requesting to add a version tag, despite the fact that I added the 5-0EA tag.

Anyways, onto my question:
Im following along with the beginner tutorial by Unreal Sensei, however Im trying to add my own stuff rather than play around with freely available stuff.
Im currently trying to create a material to put onto my landscape. For that reason I created a seamless grass texture with gimp (its 512x512 pixels) and exported it to .png, .bmp and .tga. I can import the texture into my project just fine and even view it inside unreal:

However when I drag and drop it into the material like this:

Unreal completely freezes and no matter how long I wait I have to shut it down via task manager.
Is there a step I missed? I read that it should have a power-of-two resolution and that .png and .tga are preferred.
However even at 512x512 pixels resolution and after trying .jpg, .png, .bmp and .tga it still freezes every single time.

Update: I just downloaded a texture via Quixel Bridge and again when I drop it into the material plane my UE5 just stops working.
So I guess the issue is with UE5 not with the texture itself.

Try verifying your ue5.
On the dropdown from the launcher on the engine-> verify.
This will check if the install has all files required.
What system are you running ue5 on?
I noticed a windows 7 like logo on your screenshot.

1 Like

Thank you for the idea. Just to be on the save side I let the verifier run twice but it seems to have found no problems and sadly the problem I have still persists.

Yes indeed Im on windows 7. Is that known to cause problems?

Another update:
I installed UE4 to see if it would work there. I could drag and drop my texture onto the material plane, however the small preview there showed a white square. When I then opened the texture within UE it said the following: Grass_seamless_512x512.png (Invalid texture)
Now, Im wondering what that invalid texture means.
I downloaded a texture from the web, imported it and the same thing happened, invalid texture.
I googled around but found nothing that helps.

Another update:
I downloaded this free material pack from the store. After downloading and adding it to the UE4 project the materials showed up fine within the content browser. However when I tried to open/look at them UE4 recompiled shaders and now they are messed up. The pack came with .pngs of the textures used in the material and they also show up completely black and again I get the (Invalid texture) statement when looking at them.
How is this even possible? I did a fresh install of UE4, I didnt mess around with it at all, added said material pack to the project and it still gives me this error…

Some very strange behaviour.
But i would like to try to help in some way.
I will add an image of standard settings for one of my textures.
In this case it is a 4k texture with an alpha map.
Check if there is any difference in the settings compared with your texture.

1 Like

Thank you for your help, I really appreciate it!

I checked the settings and I have exactly the same ones.

I wanted to move UE5 to a different HDD anyway so Im gonna try a fresh install now. But since I have the exact same behaviour with UE4 Im not putting too much hope into that.
EDIT: ^Did not work.

Figured Id post this aswell. Maybe it gives someone an idea what is happening:
contrary to @D13on s picture under “Displayed” and “Max In-game” it shows 1x1, even though the texture is 512x512. Also the format is unknown.

Some more updates and I hope someone can make sense of any of this.

In UE4 I imported the starter content. I COULD ACTUALLY USE a texture from that pack and drop it onto my material. This worked fine. I could even use said material in my scene.
However, as soon as I try to use either a texture I downloaded from the unreal marketplace or my own texture, it just looks white:


So, starter content works everything else doesnt.

In UE5 its even weirder. I also imported the starter content and the materials within the content drawer preview just fine. As soon as I open up a material the ShaderCompileWorker.exe process shows up in the task manager and UE freezes for a few seconds. After the process disappears UE unfreezes again. However as soon as I pan the view when looking at the material to include the textures it freezes for good and doesnt unstuck anymore.
So this works:


But if I now move the view slightly to the left it freezes, ShaderCompileWorker.exe shows up again but this time after the process disappears UE does not unfreeze again.

What makes this EVEN MORE WEIRD is that I can actually USE the material in the viewport.


When applying the material it again freezes for a few seconds but after that everything is fine. I can move the camera around, I can move the object, but as soon as I open up the exact same material that shows up in the viewport and try to look at it, I get a crash again.

One thing I remember is that I encountered this error and used the ‘dirty’ fix from post 5. Could that be related? Seems weird though because it doesnt look like anyone else on that thread has the problem that I have.

Anyway, at this point Im getting somewhat frustrated and Im close to begging for someone more experienced than me to look into this :sweat_smile:

What are your system specs?

I cannot repeat this issue on my computer, so it could be system-related if you have again installed ue5.

Im sitting on a Win7 64 bit machine with the following specs:
AMD Phenom II X4 955
Geforce GTX 1050
and 4GB DDR3 RAM

I also just tried on my laptop (only in UE4 because it cant run 5) and I dont have the issue there and its also running Win7 64bit.

Reluctantly I ‘upgraded’ my system to Windows 10 64bit. I figured maybe the fact that Nvidia doesnt provide a new Win7 driver for my graphics card anymore has something to do with my problem here.
Turns out it doesnt. Even on Win10 with the latest graphics card driver Im running into the exact same issue.
To summarize:
-Its not the texture, the exact same texture with the exact same settings works on my laptop within UE4, while it doesnt work on my PC in the same version of UE4
-Its not my OS
-Its probably not even an UE problem, afterall it works on my laptop within UE so there has to be something messed up with my PC I guess. What that would be I have literally zero clue at this point

Do something, turn the textures into virtual texture and then drag and drop to see if it works.

It could be that shaders are not compiling properly.

How much VRAM does GTX 1050 have?

Hey, thanks for the idea and sorry for the late reply. Was really busy the last days.

2GB if Im not mistaken.

Since I had no idea what this means I tried to follow this guide. Is that the approach you were talking about?
If so I got stuck at step 3 because it told me to open up an existing material. The problem here is of course that I cant create a material with the texture.